Renek Nybegynder
14. januar 2013 - 11:15 Der er 6 kommentarer og
1 løsning

Formel til betinget summering

Jeg kan ikke finde ud at få Excel til kun at summere en række tal når datoen er ens via en "magisk formel" som jeg blot kan trække ned.

http://screencast.com/t/W9UnRy2KHji

Normalt ville jeg løse det via en pivottabel, men jeg har brug for at kunne opdatere en lang række ark hurtigt samt slå op i dem, så jeg er ikke sikker på at pivot er den bedste løsning?
finb Mester
14. januar 2013 - 12:59 #1
Skal du ikke bare have en 
=sum.hvis
med dato i gåseøjne
"2013-01-14"
eller
""2013-01-14""
?
Renek Nybegynder
14. januar 2013 - 13:04 #2
Kan du skrive det som formlen ville skulle se ud? Jeg er ikke super ferm til det her :/
natkatten Mester
14. januar 2013 - 15:18 #3
Hmm, jeg ville ikke hardkode datoen ind i formlen, men løse det ved hjælp af f.eks. denne SUMPRODUKT-formel:

=SUMPRODUKT(($B$3:$B$100=$E3)*($C$3:$C$100))

Dine første datoer er her i kolonne B. De unikke datoer er i kolonne E. Værdierne, der skal summeres er i kolonne C.

Se mere:

http://gupl.dk/690108/
Renek Nybegynder
15. januar 2013 - 07:43 #4
Fantastisk - det virker! Tak :)
Renek Nybegynder
15. januar 2013 - 07:44 #5
Kan du ikke skrive igen som svar "natkatten", så jeg kan give dig point.
natkatten Mester
15. januar 2013 - 10:02 #6
Her er et svar

/natkatten
natkatten Mester
15. januar 2013 - 10:03 #7
Og nu som svar
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Advarsel til Gmail-brugerne: Lumsk phishing-mail på spil netop nu - sådan spotter du den
Gmail-brugerne skal være på vagt: It-kriminelle forsøger sig i øjeblikket med en udspekuleret phishing-mail. Se her, hvordan du spotter fupnummeret.
CIO
Årets CIO om 2017: Nu skruer vi op for kunstig intelligens for at finde mønstre i driftdata og optimere komponenter
Klumme: Hos Energinet går forretning og it nu sammen om at skabe systemer baseret på kunstig intelligens. Målet er et mere effektivt dansk el-system ved at udnytte og forstå de gigantiske datamængder fra elforsyningen.
Comon
Undgå passwordet: Smart tilbehør til at låse og åbne din computer med Windows Hello
Windows Hello kan mere end blot låse din computer op med dit ansigt. Der findes en lang række muligheder af tilbehør, som kan være med til at sikre din computer mod indtrængere. Se fem af dem her.
Channelworld
Ny EG-direktør har en plan: Sådan skal EG vokse sig større og endnu mere profitabel
Interview: Mikkel Bardram er ny administrerende direktør i EG. Selvom EG nu har 2.000 ansatte og en omsætning på 1,8 milliarder kroner, er der potentiale for endnu mere, mener den nye direktør.
White paper
Invester i nye it-systemer og øg din konkurrencefordel
Sådan øger du antallet af kunder uden at øge bemandingen, få mindre stress i hverdagen og et langt bedre forhold til kunderne end tidligere.