
Mozilla Firefox, dit alternativ til Internet Explorer
Denne artikel vil omhandle de generelle forskelle mellem Mozilla Firefox og
Internet Explorer, samt vise nogle funktioner i Firefox som vil gøre dig hurtigere
på nettet og give dig en bedre internetsurfoplevelse (fedt ord)! :)
Skrevet den 03. Feb 2009 af hermandsen I kategorien Browsere / Internet Explorer | 

Historien om Firefox
Hvis du ikke gider at læser om historien bag Firefox, kan du nemt springe videre til Skaf Firefox.

For at kende til historien om Firefox må jeg først fortælle lidt om Netscape.

Ved begyndelsen af nettet fik vi browseren Mosaic, men på bruger-niveau blev Netscape Navigator hurtigt
populær og næsten synonym for World Wide Web og internetsurf. Netscape dominerede internettet og for
at holde konkurrenterne væk opfandt Netscape tags, som f.eks. <center>, hvilket betød at web-udviklerne
brugte dem, og brugerne dermed kun kunne se siden ordentligt, hvis de brugte Netscape. En strategi som
Microsoft desværre nyder godt af i dag.

Netscape's browser kostede den gang penge, og det varede ikke længe før Microsoft fik øjnene op for at
de skulle til at sætte sig ned foran det fedtede tastatur og skrive en browser som kunne udkonkurrere
Netscape's. Det endte med Microsoft Internet Explorer, men til forskel fra Netscape, gav Microsoft deres
browser væk gratis og integrerede den med deres operativ system, Microsoft Windows.

Netscape's salg af browseren begyndte at dale, så de begyndte også at give deres browser væk. Desværre
var Netscape også langsomme til at opdatere deres browser, mens Microsoft udviklede hårdt og brutalt på
deres for tilsidst at opnå total dominans på browser-markedet.

Netscape blev mere drastiske og udgav deres browser som OpenSource, hvilket vil sige at alle kunne
udvikle på den. Det blev hurtigt til Mozilla-browseren, som mange af Netscape-folkene også udvikler på i
dag.
Mozilla-browseren var som sagt basseret på Netscape, men blev lavet meget om, for at slippe af med
dårlig kode og forbedre den eksisterende. Desværre har roadmap'et for Mozilla altid været meget uklart,
og derefter blev der udviklet helt ekstremt på browseren, og mange unødvendige funktioner begyndte
hurtigt at dukke op. Det førte samtidig til at Mozilla blev meget tung og langsom.

Folkenen bag Firefox så problemet og besluttede derfor at udvikle en browser som udelukkende havde de
funktioner der skulle til at for at surfe på nettet, og derefter kunne udvides til den enkelte bruger vha.
moduler og plugins. Dette førte til en browser uden alt muligt ekstra grejl, eller en letvægts Mozilla, som
nogle vælger at kalde den.
I starten blev denne browser kaldt Phoenix, men efter nogle <a
href="http://slashdot.org/articles/02/11/28/1246238.shtml?tid=154">navne-problemer med BIOS-
udvikleren, Phoenix Technologies</a>, ændrede Firefox navn til Mozilla Firebird. Dette var kodenavnet for
browseren et stykke tid, men som nogen af jer sikkert ved, findes der allerede et OpenSource-projekt med
navnet Firebird. Nemlig Firebird-databasen som er en vidreudvikling af Borland's InterBase. Denne blev
nemlig også frigivet som <a
href="http://info.borland.com/devsupport/interbase/opensource/">OpenSource</a> en gang. Mozilla-
folkene tog problemet til sig, og ændrede navnet til Mozilla Firefox, hvilket forhåbentlig bliver det endelige
navn for browseren. Planen går nu på at Firefox helt skal overtage Mozilla-browseren og at der skal laves
en samlet internet-pakke fra Mozilla med chat, mail og browsing. Disse skal alle basseres på måden Firefox
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er opbygget på. <a href="http://mozilla.org/products/thunderbird/">Mail-klienten</a> er også så småt
begyndt at tage form, med navnet Thunderbird.

Hvorfor du skal bruge Firefox
Der findes adskillige grunde til at vælge Firefox frem for Internet Explorer. En af de eneste fordele ved
Internet Explorer er at flertallet bruger den, og derfor at flertallet af verdens hjemmesider er lavet til kun
at blive vist i Internet Explorer. I starten brugte flertallet Netscape, men med Microsoft's monopol på
operativ systemer, blev dette hurtigt ændret. Der findes rent faktisk andre software-firmaer end Microsoft.
;)

Et stort problem ved Internet Explorer er bl.a. at den ikke længere bliver udviklet som en <a
href="http://newz.dk/forum/item/25269/">selvstændig</a> <a
href="http://slashdot.org/article.pl?sid=03/05/31/1650206">applikation</a> til Windows styresystemet,
men fremover vil følge med styresystemet som en integreret del. Dermed vil folk uden det nyeste OS fra
Microsoft være håbløst bagud med Internet Explorer version 6 + Service Pack 1.

Internet Explorer understøtter heller ikke de gældende web-standarder som er sat af World Wide Web
Consortium (W3C). Bl.a. har Internet Explorer ikke ordentlig understøttelse af CSS, XHTML 1.1 og PNG,
hvilket bliver fremtidens standarder inden for web-udvikling. Desuden er Internet Explorer's "box-model"
ikke udregnet ordentligt. En ting som Microsoft meget let kunne gøre noget ved, men om de gider!?
Men hvorfor er det så vigtigt med standarder og XHTML+CSS? Fordi vi lever i et informations samfund hvor
køleskabet og tv'et snart bliver online og skal kunne vise websider. For at holde websiderne kompatible
med fremtidens apperater, skal der laves hjemmesider efter standarder som ALLE har adgang til, ikke
Internet Explorer standarder.

<a href="http://www.xulplanet.com/ndeakin/arts/reasons.html">101 grunde til at vælge Mozilla Firefox
frem for Internet Explorer.</a>

<a href="http://features.slashdot.org/article.pl?sid=99/11/05/144251&tid=117">Kampen der kan gøre at
vi taber krigen.</a>

Skaf Firefox
Firefox kan hentes på <a
href="http://www.mozilla.org/products/firefox/download.html">http://www.mozilla.org/products/firefox/do
wnload.html</a> og er lige klar til at installere. Jeg går ud fra at du har lidt kendskab til dit OS, så jeg vil
blot bede dig om enten at hente installations-filen og installere programmet.

Brug Firefox
Firefox har mange funktioner, og de fleste af dem er underligt nok gemt lidt væk, men det kommer vi ind
på senere.
De "vigtigste" funktioner vil jeg dog prøve at komme ind på her:

Tabbed browsing
Måske sidder du ofte med 6-7 browser-vinduer åbne, måske mere, måske mindre. Dette er både
uoverskueligt, og forvirende hvis der er andre prorgammer åbne samtidigt. Her kommer Firefox med en
funktion der kan holde dine websider i én browser, nemlig tabbed browsing. Altså at indele siderne i tabs i
stedet for nye vinduer.
For at åbne en ny tab skal du trykke Ctrl+T.
Ønsker du at åbne et link i en ny tab kan du holde Ctrl nede og trykke på linket, eller du kan trykke på
linket med den miderste muse-knap (f.eks. scroll-hjulet).

Type-A-Head
Skal du finde et link hurtigt, eller søge på en webside kan du bruge type-a-head-funktionen.
Lad os sige at der er et link til http://www.ebruger.dk/ med navnet "eBruger". Ekspempel: <a
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href="http://www.ebruger.dk/">eBruger</a>. Hvis vi skal hurtigt ned til det link skriver vi bare lidt af
navnet på linket. Skriver vi f.eks. R-U-G (ebRUGer), så bliver hopper Firefox ned og markerer linket og viser
hvad du har skrevet. Her er linket markeret og "eB" og "er" står som normalt, mens "rug" er markeret med
grønt for at indikere det fundne link. Hvis du skal videre til næste link trykker du bare F3, og vupti.

Ønsker du i stedet at søge i almindelig tekst, skal du starte med at trykke på / (frontslash), og så virker
funktionen ligesom ved links.

Udseende
Ligesom i Internet Explorer kan du flytte rundt på knapperne og delene i Firefox's toolbar-struktur. Dette
gøres simpelthen ved at vælge View->Toolbars->Customize, og så bare lave træk/slip med de enkelte
dele. Du kan også trække knapperne op ved siden af menu'en. Ønsker du at fjerne en hel toolbar kan det
gøres under View->Toolbars->Navigation toolbar og View->Toolbars->Bookmarks toolbar.

Som noget andet understøtter Firefox også Themes, hvilket betyder at du kan ændre på Firefoxs udseende
så det passer til dig. Nogen vil gerne have meget grafik, mens andre hellere vil have så lidt som muligt.
Ligemeget hvad du synes bedst om, så får du i hvert fald et stort <a
href="http://www.texturizer.net/firefox/themes.html">udvalg</a>.
For at installere et theme klikker på bare på "Install"-linket. Firefox henter derefter theme'et, installerer
det og det eneste du nu skal gøre er at genstarte browseren. Har du flere favoritter, kan du skifte theme
under menu'en Tools->Options...->Themes.

Plugins
Firefox understøtter <a href="http://www.texturizer.net/firefox/extensions.html">plugins</a>, eller <a
href="http://extensionroom.mozdev.org/">extentions</a> som de også kaldes.
Jeg vil ikke komme nærmere ind på hvilke plugins der er rigtige og forkerte, eller hvordan de installeres,
da det er lige ud af landevejen. Dog er det en god ide at bruge nogle minutter til at kigge de forskellige
plugins i gennem og se hvad man synes om. Selv er jeg glad for Session Saver, Web Developer, Nuke
Anything og Flash Click To View, men dan dig hellere dit eget indtryk og vær ikke bange for at forsøge dig
frem.
Hvis du er blevet træt af et plugin, åbner du bare Tool->Options...->Extentions, vælger plugin'et og trykker
på "Disable Extension"-knappen.

Download manager
Firefox har en indbygget Download manager, som gør det lettere og hurtigere at hente filer fra nettet. Et
klik på et link, du bliver spurgt om du vil åbne filen med det samme, eller hente den til din download-
mappe. Vælg selv en standard-mappe under Tools->Options...->Downloads. Skal du bare hente mange
filer et sted, kan du også åbne Download-vinduet med et tryk på Ctrl+E, og så ellers trække og slippe
linket over i vinduet.

Flere indstillinger
For at komme ind til kerne-indstillingerne for Firefox skriver du bare about:config i adresse-linien og finder
det du vil <a href="http://preferential.mozdev.org/preferences.html">ændre</a>. I starten kan det hele
godt virke lidt uoverskueligt, men det er der selvfølgelig råd for med <a
href="http://preferential.mozdev.org/installation.html">Preferential-plugin'et</a>, men kig dig lidt frem
og pas på hvad du gør!!!

Fortæl andre om Firefox
Nu hvor du endelig er overbevist om at Firefox er fremtidenes browser, så er der kun tilbage at sprede
rygtet om denne fantastiske browser. Fortæl dinne venner om den, familie, skolen/firmaet, opret en nyhed
på SlashDot, lav en artikel som denne, link til den når der snakkes om browsere og fortæl i det hele taget
om den vidt og bredt!

Tillykke med din nye browser!
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//hermandsen

Kommentar af janomel d. 07. May 2004 | 1

Men hvad med netbank. Bruger nordea. Det er altså skod i Mozilla og Opera. Men dejligt at få en
gennemgang af browseren

Kommentar af simonvalter d. 24. Jan 2004 | 2

god artikel, skod browser .. eller ..jeg er bare stadig lidt sur på firebird for at have overtaget ejerskabet af
*.xml filer på min computer... det har den sq ikke noget at gøre med og xml spy klarede det fint før. og så
er der stadig en del sider der ikke bliver vist alt for godt i den og den opfører sig lidt mærkeligt engang ..
imellem, feks her hvor en side har det med at være blank første gang man ser den indtil man refresher...
men den er jo heller ikke final endnu.

Kommentar af olebole d. 17. Dec 2004 | 3

Firefox er en fortrinlig browser, meeeeen det var altså ikke den, Moses havde med ned fra bjerget ... FF
har - som alle andre browsere - også sine fejl ;o)
At FF understøtter XHTML bliver fint engang i fremtiden, når brug af XHTML på WWW bliver aktuelt - men
sådan er det endnu ikke.
Derudover er det faktisk op til koderen, hvordan IE skal tolke og behandle box-modellen.
Fin artikel, omend den har en let bismag af religion ... men andet venter Hermandsen heller ikke, jeg
skriver  ;D

Kommentar af skovenborg d. 12. Jan 2004 | 4

Kan ikke være mere enig. IE er efter min mening også kun for folk der ikke har prøvet andet - selv min mor
bruger Firebird. Rigtig fin artikel :-)

Kommentar af metal_hansen d. 12. Jan 2004 | 5

Dét er god e-bruger humor ;)

Kommentar af athlon-pascal d. 12. Jan 2004 | 6

Super artikel!
Men opdater lige linkene til diverse extensions, da extension-delen på texturizer.net/firebird længe har
været nede - extensionroom.mozdev.org er alternativet!

Kommentar af zchou d. 12. Jan 2004 | 7

Har længe tænkt mig at prøve Firebird. Denne artikel motiverede mig til at få det downloadet. Jeg er
positivt overrasket, men man skal nok lige vende sig til at vinduerne ligger "tabbed" i ét browservindue.
Tror dog jeg bliver glad for det:o)

Kommentar af mccannon d. 16. Apr 2004 | 8

For at sige det kort, INGEN browser OVERHOVDET overholder w3 standarder 100%!.
Artiklen nærmer sig det sædvanlige med at "MS køre deres eget løb og egentlig er noget skod."
Men det er udemærket alternativ til IE.

Kommentar af kkd d. 15. Nov 2004 | 9



Artiklen er da fin, men mangler nuamncer. Det er meget muligt at Firefox er den bedste browser, men et
lidt mindre snævert syn på sagen havde pyntet.

Kommentar af antrax d. 05. Sep 2004 | 10

Meget omfattende, rigtig god artikel! :)

Kommentar af ldrada d. 12. Jan 2004 | 11

God artikel.
Jeg er lige skiftet fra den bloatede Mozilla ( http://www.google.com/search?q=define:bloated, hvilket den
virkelig er.) men jeg er bange for at jeg bliver nødt til at køre IE og Mozilla synkront :)

Kommentar af exp d. 12. Jan 2004 | 12

Den BEDSTE browser :-D

Kommentar af lordhead d. 12. Jan 2004 | 13

Jeg synes den viser godt og grundigt, hvordan Mozilla Firebird fungere. Jeg har selv fået nytte ud af
artiklen, da jeg ikke vidste der fandtes themes, extentions osv.

Altså - Fremragende!

Kommentar af squashguy d. 12. Jan 2004 | 14

Firebird styrer! og jeg glæder mig til, at jeg skal surfe sammen med mit køleskab :)

Kommentar af neo2k d. 28. Jul 2004 | 15

God artikkel :D FIREFOX RLZ

Kommentar af ymmot69 d. 13. Jan 2004 | 16

jeg har nu længe hørt om denne browser... og kun godt.. denne artikel har givet mig endnu mere lyst til at
prøve den af.. dog har jeg hele tiden en irriterende tanke i mit hovede der siger: at måske er de folk der
anbefaler firebird og hakker på ie i virkeligheden bare et stort had til Bill G og hans kumpaner.. Er det det
det handler om?  eller er det virkeligt fordi at det er sandt ... hmmm *S* men tak for artiklen anyways.. tror
jeg vil prøve det af...

Kommentar af kalb d. 03. Dec 2004 | 17

Giver et ok vue over firefox for tvivlere.

Kommentar af thedeathart d. 12. Jun 2004 | 18

Hvad kan man sige... FIREFOX OWS...
og super artikel... Hvis en side ser forkert ud i Firefox, så er det ikke browsren det er galt med, men
siden...
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