Avatar billede petersen7913 Forsker
14. juni 2021 - 15:44 Der er 2 kommentarer og
1 løsning

Default værdi for et Double felt fungerer ikke

Jeg har en tabel med feltet [Sales volume]
Det er defineret som Double, formatteret med #.###, Default value er sat til 0.

I samme tabel har jeg et andet felt defineret som currency og også med default value = 0.

Når jeg åbner tabellen som Sheet vises currency feltet fint med 0,00 kr som default value, men ikke [Sales volume]. ?????

I min kode har jeg bl.a. en Insert into tabelen... hvor jeg eksplicit sætter [Sales volume] til 0 ....Når jeg ser på dataene i tabellem bagefter ar alt gået godt i min insert UNDTAGEN [Sales volume], der stadig er Null.

Jeg har prøvet at åbne tabellen son Sheet og taste 0 ind i feltet - der bliver fjernet lige så hurtigt jeg forlader feltet.Jeg kan taste andre værdier også i min Insert men 0 .....???????

Nogen gode ideer????????

Pft
Avatar billede Gustav Professor
14. juni 2021 - 15:58 #1
Sæt formatet til: #.##0
Avatar billede petersen7913 Forsker
14. juni 2021 - 16:03 #2
Jeg prøver - tak

Jeg læser først data fra et regneark ind i en temporær table. der kan jeg se, at hvis jeg sætter feltet til 0 i regnearket bliver det læst korrket ind som 0 i den temåporær tabel. Men det kommer ikke med over i den rigtige tabel.
Avatar billede petersen7913 Forsker
14. juni 2021 - 16:10 #3
TAAAAAK :)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Årets CIO 2022: Nu skal Danmarks dygtigste CIO findes - er det dig? Eller kender du en, du vil indstille?