Nicolai Madsen Praktikant
26. januar 2021 - 20:40 Der er 7 kommentarer

LOPSLAG

Hej

Må man ikke anvende Clear som ord, der skal slås op med denne funktion?

Jeg har en simpel tabel med tre linjer, og tre kolonner, på et ark som kaldes Data

MobilePay      1          12
NETS            2          13
Clear              3          14

Så skal jeg slå dette op, på et andet ark som hedder kontor

Clear

jeg skriver formlen sådanne
=LOPSLAG(C2;Data!A2:C4;3)

Lige for at understrege det, så står opslags værdien (Clear) i C2.

Det der sker er at den siger #I/T, men prøver jeg sætte et af de 2 andre ord ind i C2 på ark kontor, så virker det fint.

Det som jeg synes er meget mærkeligt, er hvis jeg blot både på ark Data og ark Kontor, ret Clear til qClear, så slår den det rigtige tal op.

Derfor spørger jeg om det "ulovligt" at bruge Clear? eller om der kan være en anden årsag til dette?
ebea Ekspert
26. januar 2021 - 21:38 #1
Du mangler en lille detalje i din formel:    =LOPSLAG(C2;Data!A2:C4;3;0)
kim1a Ekspert
27. januar 2021 - 09:26 #2
Har du checket om der evt. skulle være et mellemrum i efter Clear? Det har oftet drillet mig.
dp2001 Juniormester
27. januar 2021 - 15:48 #3
Vel bare et klassisk eksempel på at du skal huske $

=LOPSLAG(C2;Data!A$2:C$4;3;0)

Ellers bliver opslagsområdet "forskudt" og den kan ikke finde Clear-værdien.
ebea Ekspert
27. januar 2021 - 16:26 #4
#3 - Hvorfor skulle det ændre noget, i tilfældet med hans opstilling?

Hans formel virker korrekt nok, men manglede et SAND/FALSK argument til sidst i formlen (et 0)
Nicolai Madsen Praktikant
27. januar 2021 - 16:42 #5
Har desværre ikke lige testet det endnu, men hvorfor skulle det hjælpe med den der sandt/falsk til sidst?
Nicolai Madsen Praktikant
27. januar 2021 - 16:43 #6
Som sagt virker de andre uden sandt/falsk.
ebea Ekspert
27. januar 2021 - 16:47 #7
#5 - Fordi du får returneret det korrekte opslag!
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Trump bønfalder Helle Thorning: Giv mig min Facebook-konto tilbage
Facebooks tilsynsråd, der har Helle Thorning-Schmidt i spidsen, har modtaget en erklæring fra Donald Trump, som ønsker at få genoprettet adgangen til sin Facebook og Instagram-konto.
CIO
Der findes ikke noget vigtigere for din virksomhedskultur end psychological safety
Klumme: Forskningen er entydig: Vidensarbejde er mere effektiv, når du tør stille spørgsmål, rejse kritik og indrømme fejl helt uden frygt for at blive straffet eller gjort til grin. Hvis du ikke har fokus på denne del af din virksomhedskultur, så lever din virksomhed og dine medarbejdere ikke op til deres fulde potentiale.
Job & Karriere
IBM Danmark trækker tilbud om frivillige fratrædelser tilbage for stort antal ansatte: "IBM har taget røven på sine ansatte"
Som led i IBM Danmarks store fyringsrunde fik 130 ansatte grønt lys til at forlade selskabet på en frivillig fratrædelsesordning. Men nu har IBM Danmark trukket det oprindelige tilbud tilbage for størstedelen af de ansatte.
White paper
Gratis whitepaper: Hvad er EDI, og hvordan kan det styrke min forretning?
Overvejer du EDI, og ønsker du at undersøge, om EDI er den rette investering for din virksomhed? Har en af dine kunder eller leverandører for nyligt bedt dig om at udveksle elektroniske dokumenter (EDI)? Så hent dette whitepaper og få et overblik over, hvad EDI er, og hvilke fordele producenter og grossister som dig kan se frem til, når du investerer i EDI til din forretning.