Avatar billede pep_panic Nybegynder
25. juli 2005 - 14:19 Der er 7 kommentarer og
1 løsning

DNS, Exchange, AD og Application Directory Partition

Hej Guru'er
Har et mystisk problem med vores DC (server 2003) og Exchange 2003.

Pludselig vel Exchange ikke sende mails - internt som eksternt - og min debug af problemet har ført mig vidt omkring.

Efter noget tid er jeg kommet frem til, at vores DNS laver noget mystisk. DNS'en har ingen ADP (application directory patition). En eller anden klokke ringer i mit baghoved fordi dns'en er ret vigtig for Exchange. Nedenstående er en copy fra en cmd.

C:\WINDOWS\support tools>dnscmd /DirectoryPartitionInfo /detail
Directory partition info query failed
    status = 9901 (0x000026ad)

Command failed:  DNS_ERROR_DP_DOES_NOT_EXIST    9901
(000026ad)

C:\WINDOWS\support tools>ipconfig /all

Windows IP Configuration

  Host Name . . . . . . . . . . . . : server-1
  Primary Dns Suffix  . . . . . . . : Thorup-Gruppen.local
  Node Type . . . . . . . . . . . . : Unknown
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No
  DNS Suffix Search List. . . . . . : Thorup-Gruppen.local

Ethernet adapter Local Area Connection:

  Connection-specific DNS Suffix  . :
  Description . . . . . . . . . . . : IBM Netfinity Fault Tolerance PCI Adapter

  Physical Address. . . . . . . . . : 00-06-29-A8-7F-2F
  DHCP Enabled. . . . . . . . . . . : No
  IP Address. . . . . . . . . . . . : 192.168.0.100
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Default Gateway . . . . . . . . . : 192.168.0.60
  DNS Servers . . . . . . . . . . . : 192.168.0.100
                                      194.239.10.40

Er en ADP nødvendig for Exchange? Og kan jeg bare oprette en ny ADP uden at skade (mere end allerede er galt) noget?

På forhånd tak for hjælpen.
/Pep
Avatar billede screem_brille Novice
25. juli 2005 - 14:25 #1
den sekundære DNS burde ikek stå der, men være under forwarders istedet for, tror ikke det har med fejlen at gøre, men den burde ikke være der ;)
Avatar billede pep_panic Nybegynder
25. juli 2005 - 14:27 #2
Ok, den fjernes... men hvad med resten (ADP)?
Avatar billede screem_brille Novice
25. juli 2005 - 14:29 #3
der må jeg lige melde pas :/ (lige nu)
Avatar billede bufferzone Praktikant
25. juli 2005 - 14:31 #4
Hmmmmm jeg kan ikke rigtig finde noget. Kunne du kikke i din event viewer og se om der skulle være nogle brugbare entries. Post event ID'erne, det kunne måske give en brugbar indgang
Avatar billede pep_panic Nybegynder
25. juli 2005 - 15:11 #5
Tjaa, en entry som er nogle dage gammel. Kom i forbindelse med en restart pga. en opdatering. Siden ingen (DNS) fejl i event-loggen. En hvis forbindelse kan jeg godt se, men fejlen er ikke set siden, ergo regnede jeg med, at det blot var noget midlertidigt som systemet selv fixet.


Starter med en fejl d. 13. juli:
Source: DNS, eventID 4015
Source: DNS, eventID 4004
plus fire 4004 mere hvor af den sidste ser således ud:
---
The DNS server was unable to complete directory
service enumeration of zone Thorup-Gruppen.local.
This DNS server is configured to use information
obtained from Active Directory for this zone and is
unable to load the zone without it.  Check that the
Active Directory is functioning properly and repeat
enumeration of the zone. The extended error debug
information (which may be empty) is "". The event data
contains the error.
---

Tak fordi i gider kigge på det.
/Pep
Avatar billede bufferzone Praktikant
25. juli 2005 - 15:45 #6
Det gav ikke noget umiddelbart, jeg søger lidt endnu
Avatar billede pep_panic Nybegynder
25. juli 2005 - 15:57 #7
Den her fejl får jeg fra exchanges NDR's. "5.1.7 Invalid or missing sender SMTP address"
http://support.microsoft.com/?kbid=284204
Se et stykke nede under "Numeric Code: 5.1.7"

Tror disse ting hænger sammen, men forstår ikke helt microsofts fix'it tekst.
Avatar billede pep_panic Nybegynder
25. juli 2005 - 18:29 #8
Jeg kan berette, at en reinstall af exchange var nødvendig. Dette ændrede ikke på allerede etablerede mailbox's og alt virker uden problemer igen.

Tråden er hermed lukket.
/Pep
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview
Kategori
IT-kurser om Microsoft 365, sikkerhed, personlig vækst, udvikling, digital markedsføring, grafisk design, SAP og forretningsanalyse.

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester