torbenhawk Praktikant
29. marts 2011 - 19:51 Der er 2 kommentarer og
1 løsning

Hvordan finder man og midler et array omkring en max værdi?

Hej experter.
Jeg sidder og roder med noget excel.
Jeg har en kolonne med data (1440 rækker) som jeg gerne vil finde max og min af, det er i sig selv let nok, men det er måledata med lidt støj på. Så for ikke kun at fange den højeste/laveste støjpuls på det højeste/laveste sted på kurven, vil jeg gerne midle ca. 6 samples på hver side af mine ekstremaer. Jeg har fundet ud af at bruge =MAX og derefter =MATCH til at finde den række med de fuldende ekstremaer, men derfra og så til at finde et 13 samples array med MAX eller MIN i midten og derefter midle ved jeg ik hvordan man gør.

Hvis det ikke fremgård af spørgsmålet vil jeg lige nævne at jeg ikke er nogen excel-haj, så jeg håber problemet kan løses uden Visual Basic.

På forhånd tak.
30. marts 2011 - 09:25 #1
For mig er det uklart, hvad du mener. Skal det forstås sådan, at hvis for eksempel minimumsværdien står i celle A7, så vil du have midellværdien af A1:A13. Hvis JA, hvad så hvis minimumsværdien står for eksempel i A3 eller i A1438?

Rent bortset fra det, kunne du så ikke prøve at skrive almindelig dansk i stedet for det der rædselsfulde Danglish?

Hans
excelent Ekspert
30. marts 2011 - 15:32 #2
Middelværdien af de 6 mindste tal :
=MIDDEL(MINDSTE(A1:A1400;{1;2;3;4;5;6}))

Middelværdien af de 6 største tal :
=MIDDEL(STØRSTE(A1:A1400;{1;2;3;4;5;6}))

Begge formler afsluttes med ctrl+shift+enter (matrixformler)
torbenhawk Praktikant
03. januar 2012 - 10:32 #3
Tak for indlægene. Jeg fandt selv en anden løsning hvor jeg brugte add. på cellerne.
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Midt i spionage-rygter og mediestorm: Computerworld besøger Huawei i Kina - tag med på besøg hos det måske mest omstridte tech-firma lige nu
Reportage, Shenzhen: “Exacting, rigorous, tests drive learning, all for real battles.” Computerworld er taget på besøg i det gigantiske hovedkvarter for verdens måske mest omtalte tech-selskab lige nu
Computerworld
Nvidias nyeste GTX 1660 kort beviser, at det igen er blevet interessant at købe grafikkort
Nvidia giver gamere i mainstream-segmentet et stærkt kort til en rimelig pris.
CIO
Tech fra Toppen: Det har CIO Mads Madsbjerg Hansen fra FLSmidth lært af flere års global it-konsolidering
Tech fra Toppen: Flere års arbejde har betydet en reduktion i antallet af it-systemer hos FLSmidth. Men processen har ikke været uden overraskelser. Hør hvad CIO Mads Madsbjerg Hansen har lært af den omfattende og globale proces.
Job & Karriere
Efter blodrødt regnskab: Nu fyrer Atea 20 medarbejdere i Danmark
Atea fyrer nu 20 medarbejdere. Det sker som en direkte konsekvens af, at den danske forretning er under pres, oplyser selskabets direktør.
White paper
Kvartalsrapport på cyber-trusselslandskabet
I denne rapport dykker vi ned i cyber-trusselsbilledet for Q4. Vi har opsummeret statistikkerne fra millioner af trusselsforekomster observeret af Fortinet enheder i live produktionsmiljøer i hele verden. Ifølge IDC er Fortinet den mest adapterede netværks-sikkerhedsløsning, med 4,2 mio. implementerede devices. Det giver et unikt perspektiv på trusselslandskabet, som er destilleret ned i denne rapport. Download den her og få det fulde overblik.