torbenhawk Praktikant
29. marts 2011 - 19:51 Der er 2 kommentarer og
1 løsning

Hvordan finder man og midler et array omkring en max værdi?

Hej experter.
Jeg sidder og roder med noget excel.
Jeg har en kolonne med data (1440 rækker) som jeg gerne vil finde max og min af, det er i sig selv let nok, men det er måledata med lidt støj på. Så for ikke kun at fange den højeste/laveste støjpuls på det højeste/laveste sted på kurven, vil jeg gerne midle ca. 6 samples på hver side af mine ekstremaer. Jeg har fundet ud af at bruge =MAX og derefter =MATCH til at finde den række med de fuldende ekstremaer, men derfra og så til at finde et 13 samples array med MAX eller MIN i midten og derefter midle ved jeg ik hvordan man gør.

Hvis det ikke fremgård af spørgsmålet vil jeg lige nævne at jeg ikke er nogen excel-haj, så jeg håber problemet kan løses uden Visual Basic.

På forhånd tak.
30. marts 2011 - 09:25 #1
For mig er det uklart, hvad du mener. Skal det forstås sådan, at hvis for eksempel minimumsværdien står i celle A7, så vil du have midellværdien af A1:A13. Hvis JA, hvad så hvis minimumsværdien står for eksempel i A3 eller i A1438?

Rent bortset fra det, kunne du så ikke prøve at skrive almindelig dansk i stedet for det der rædselsfulde Danglish?

Hans
excelent Ekspert
30. marts 2011 - 15:32 #2
Middelværdien af de 6 mindste tal :
=MIDDEL(MINDSTE(A1:A1400;{1;2;3;4;5;6}))

Middelværdien af de 6 største tal :
=MIDDEL(STØRSTE(A1:A1400;{1;2;3;4;5;6}))

Begge formler afsluttes med ctrl+shift+enter (matrixformler)
torbenhawk Praktikant
03. januar 2012 - 10:32 #3
Tak for indlægene. Jeg fandt selv en anden løsning hvor jeg brugte add. på cellerne.
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
OnePlus 7 Pro til test: Nu er selskabet i stand til at banke mobilverdenens giganter
Det kinesiske selskab OnePlus vil ind i det fine selskab af topproducenter med OnePlus 7 Pro. Missionen er lykkedes.
Computerworld
Google blokerer med omgående virkning for Huaweis brug af Android-licenser - se hvad det kommer til at betyde for dig
Google begrænser med omgående virkning kinesiske Huaweis brug af Android. Huawei vil ikke længere have adgang til tjenester fra Google.
CIO
CIO Jesper Riis fra DSV: Sådan arbejder jeg med governance så omkostninger og kompleksitet kan begrænses
Der er dømt stram governance hos Jesper Riis, CIO for verdens femtestørste transportvirksomhed. Men det er samtidig en betingelse for innovationen slår han fast. Hør mere om ledelse, performancekultur og vision hos globale DSV med de danske rødder.
Job & Karriere
"Vi var fem mennesker, der fik 400 millioner kroner, et lokale på 12 m2 og et stempel fra Undervisningsministeriet. Det kalder jeg mit første start-up. Det blev til IT-Universitetet. "
"Da jeg var færdig med PhD´en så var vi fem mennesker, der fik 400 millioner kroner, et lokale på 12 m2 og et stempel fra Undervisningsministeriet. Så skulle vi bare have et nyt universitet op og køre på seks måneder. Det kalder jeg mit første start-up. Det blev til IT-Universitetet."
White paper
Remove the Dinosaurs - Service Management with Micro Focus SMAX
Based on an EMA research, ITSM related initiatives are able to provide a hub of innovation for all of IT. The key lays in the investment of more dynamic processes and a higher degree of automation. Furthermore the value resides in a faster and easier deployable and adoptable solution. The Service Management Automation suite (SMAX) from Micro Focus is providing you the optimal solution to enable new levels of efficiency and effectiveness – moving you forward in your digital transformation.