Avatar billede Nummee Mester
05. maj 2017 - 18:50 Der er 19 kommentarer og
4 løsninger

Beregning af dagseddel - pause, blank celle og 0

Jeg har oprettet en dagseddel hvor jeg indtaster mine mødetider og sluttider

I celle D9 har jeg start tid for min dag feks. 06:00
I celle D10 har jeg min slut tid for min dag feks. 14:30
De to tider bliver så regnet ud i celle D11 med formlen =(D9-D10)*24
Dvs min arbejdsdag bliver i celle D11 8,5 timer

Så vil jeg gerne have den til at trække pause fra i celle D12 hvis D11 er større end 4,5 timer hvis mindre end 4,5 timer skal celle D12 være 0

I celle D13 regner den så mine total timer ud her skal den så skrive 8 timer når pause i celle D12 er trukket fra der bruger jeg så formlen =(D11+D12)

Og så kommer jeg så til sidste problem hvis celle D9 og D10 er tomme skal cellerne D11, D12 og D13 være blanke.

Håber jeg har forklaret mig rigtigt og en af jer kan hjælpe mig med mit problem ?

Jeg har lagt mit excel dokument her www.clandisa.dk/Dagseddel.xlsx
Avatar billede store-morten Ekspert
05. maj 2017 - 19:41 #1
Det kan du ikke, med den formatering du bruger.
Avatar billede store-morten Ekspert
05. maj 2017 - 19:59 #2
Formater cellerne D11, D12 og D13 som tal.

Prøv så disse formler:
I celle D11: =HVIS(D10="";"";(D10-D9)*24)
I celle D12: =HVIS(D11="";"";HVIS(D11>4,5;0,5;0))
I celle D13 =HVIS(D12="";"";(D11-D12))
Avatar billede Nummee Mester
05. maj 2017 - 20:27 #3
Jeg har formateret cellerne D11, D12 og D13 som 0,00;[Sort]0,00

Så har jeg skrevet de formler du skrev og nu ser det ud til at virke :-)

Takker tusind gange for din hjælp
Avatar billede store-morten Ekspert
05. maj 2017 - 20:44 #4
Ja, det konstaterede jeg også, hvorfor brugerdefineret format i stedet for: tal
Avatar billede Nummee Mester
05. maj 2017 - 21:05 #5
Jeg har rettet det til tal, det var fordi den blev ved med at skrive minus og i rød farve men det er fixet nu.

Har dog lige en sidste ting til.

Cellerne K11 til K14 og K18 til K26 skal også være blanke hvis ingen tekst i cellerne feks D18 til J18
Avatar billede Nummee Mester
05. maj 2017 - 21:14 #6
Den skal stadig lægge cellerne D18 til J18 sammen :-)
Avatar billede store-morten Ekspert
05. maj 2017 - 21:40 #7
Mener du sådan?
K11: =HVIS(SUM(D11:J11)=0;"";SUM(D11:J11))
Avatar billede Nummee Mester
05. maj 2017 - 22:01 #8
Igen utrolig mange tak for din hjælp :-)
Avatar billede store-morten Ekspert
05. maj 2017 - 22:04 #9
Velbekomme :-)
Avatar billede Nummee Mester
25. maj 2017 - 19:58 #10
Jeg har lige et spørgsmål mere

Jeg bruger denne formel i A20
=HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK))

A20 skal være blank hvis der ikke er tastet noget ind i D20
Avatar billede Nummee Mester
25. maj 2017 - 20:10 #11
Jeg har prøvet med

=HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)=HVIS(D20="";"";(D20)))

og

=HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)=(D20="";"";(D20)))

Men det virker heller ikke :-(
Avatar billede store-morten Ekspert
25. maj 2017 - 20:42 #12
Prøv:
=HVIS(D20="";"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))
Avatar billede Nummee Mester
28. maj 2017 - 12:18 #13
Tak det virker :-)
Avatar billede Nummee Mester
11. juni 2017 - 08:00 #14
Kan man lave det så cellerne E20 til J20 også gør det samme ?
Avatar billede store-morten Ekspert
11. juni 2017 - 10:43 #15
Prøv:
=HVIS(D20>0;"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))
Avatar billede store-morten Ekspert
11. juni 2017 - 11:01 #16
Der er en fejl, rettet til:
=HVIS(K20>0;"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))
Avatar billede Nummee Mester
11. juni 2017 - 18:22 #17
Tak men det virker ikke og så skrev jeg forkert, cellerne D20 til J20 hvis de er tomme skal der intet tekst være i celle A20 men hvis der er tekst i Celle D20 til J20 Skal den hente data til A20

Formular der bruges i celle A20 er og som du har skrevet tidligere
=HVIS(K20>0;"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))

Bruger jeg denne kommer der ikke noget tekst i celle A20
Avatar billede store-morten Ekspert
11. juni 2017 - 18:54 #18
Celle D20 til J20 bliver lagt sammen i K20.
Er der en sum formel i K20?
Avatar billede store-morten Ekspert
11. juni 2017 - 19:02 #19
K20: =SUM(D20:J20)

Ellers prøv med:
=HVIS(SUM(D20:J20)>0;"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))
Avatar billede Nummee Mester
12. juni 2017 - 18:29 #20
Ja der er en sum formel i K20
=HVIS(SUM(D20:J20)=0;"";SUM(D20:J20))

Har prøvet som du skrev med
=HVIS(SUM(D20:J20)>0;"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))

A20 er stadig blank selvom jeg skriver feks. 2 i alle cellerne D20 til J20 :-(
Avatar billede store-morten Ekspert
12. juni 2017 - 19:03 #21
=HVIS(K20="";"";HVIS(VOPSLAG($A$2;AFD;11;FALSK)="";"";VOPSLAG($A$2;AFD;11;FALSK)))
Avatar billede Nummee Mester
12. juni 2017 - 20:53 #22
Så virker det mange tak for din expert hurtige hjælp :-)
Avatar billede Nummee Mester
09. maj 2019 - 22:03 #23
Jeg har nu et problem igen da mit firma er begyndt at aflønne os efter pr. minut.

Lad os sige jeg møder kl.07:00 det taster jeg i celle D9
Min slut tid på arbejdet er nu 15:57 det taster jeg i celle D10
I celle D11 regner den så den nye tid ud i timer og minutter i D11 bruger jeg folmen =HVIS(D10="";"";(D10-D9)*24) men nu står mine timer så som 8,97 jeg vil gerne have der nu står 8,58 s¨det sammen når jeg ligger alle dagen sammen til sidst fra celle D11:J11 i celle K11 hvor fomlen er =HVIS(SUM(D11:J11)=0;"";SUM(D11:J11)) skal der nu også stå 8,58 timer feks. hvis jeg arbejder 8,58 timer og næste dag også arbejder 8,58 skal totalen gerne bliver 17,56 timer

Håber i kan hjælpe mig med denne ?
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Stort CIO-interview: Lemvigh-Müllers milliard-omsætning er blevet digital