JensV Juniormester
26. november 2020 - 12:07 Der er 7 kommentarer og
2 løsninger

eksekvere sammensat formel?

Hvordan indtastes en formel sammensat af tekst og reference a la dette:

=INDEKS(U62:U&lastrow("L")&;SAMMENLIGN(P56;M62:M&lastrow("L")&;0))

hvor funktionen "lastrow("L") afleverer rækkenummeret på den sidste celle i kolonne "L", f.eks. 101
thomas_bk Guru
26. november 2020 - 12:22 #1
I excel er der ikke en 'lastrow' formel.
JensV Juniormester
26. november 2020 - 13:15 #2
Den har jeg selv lavet, men hvad med mit spørgsmål?
xl-Enthusiast Ekspert
26. november 2020 - 13:37 #3
=INDEX(U62:INDEX(U:U;W62);MATCH(P56;M62:INDEX(M:M;W62);0))

hvor W62 indeholder lastrow.

dansk

=INDEKS(U62:INDEKS(U:U;W62);SAMMENLIGN(P56;M62:INDEKS(M:M;W62);0))
thomas_bk Guru
26. november 2020 - 13:37 #4
xl-Enthusiast Ekspert
27. november 2020 - 07:26 #5
Hvorfor bruger du i øvrigt ikke Excel tabel og strukturerede referencer i din formel? Herved behøver du overhovedet ikke spekulere på lastrow.
JensV Juniormester
27. november 2020 - 09:23 #6
I øvrigt bruger jeg ikke strukturerede referencer, fordi tabellerne ofte er dynamiske og altså ændrer størrelse.
Det jeg efterlyste kan uddybes som følger:

1) =HVIS(ER.FEJL((B3+B5+B7+B9+B11)/B13);"Fejl";(B3+B5+B7+B9+B11)/B13)
2) =HVIS.FEJL((B3+B5+B7+B9+B11)/B13;"Fejl")

I 1) skal man gentage en del af betingelsen, for at få den udført.
Det behøver man ikke i 2)

Så hvis man kunne få 3) lavet om til 4) og/eller 5), var mine bønner blevet hørt (afhængig af, hvad man ønsker):

3) =HVIS(1<((B3+B5+B7+B9+B11)/B13);(B3+B5+B7+B9+B11)/B13);0)
4) =HVIS.FALSK(1<((B3+B5+B7+B9+B11)/B13);0)
5) =HVIS.SAND(1<((B3+B5+B7+B9+B11)/B13);0)
JensV Juniormester
27. november 2020 - 09:38 #7
Hvordan indtastes en formel sammensat af tekst og reference a la dette:

=INDEKS(U62:U&lastrow("L")&;SAMMENLIGN(P56;M62:M&lastrow("L")&;0))

hvor funktionen "lastrow("L") afleverer rækkenummeret på den sidste celle i kolonne "L", f.eks. 101

Efter lidt forsøg og søgen endte jeg her:
=INDEKS(INDIREKTE("U62:U"&lastrow("L"));SAMMENLIGN(P56;INDIREKTE("M62:M"&lastrow("L"));0))
xl-Enthusiast Ekspert
27. november 2020 - 09:39 #8
Hvad har #6 at gøre med dit oprindelige spørgsmål?

Jeg prøvede at besvare dit spørgsmål i #3, men det finder du åbenbart ingen anledning til at kommentere. I stedet synes jeg du opstiller et helt nyt scenarie.

Din bemærkning, at I øvrigt bruger jeg ikke strukturerede referencer, fordi tabellerne ofte er dynamiske og altså ændrer størrelse ...

giver ingen mening. Strukturerede referencer tager netop hensyn til dynamiske tabeller.
JensV Juniormester
27. november 2020 - 09:51 #9
Ja, jeg kom lige til at blande to spørgsmål sammen :-(

Jamen, så må jeg til at dyrke strukturerede referencer noget mere :-)
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester



Seneste spørgsmål Seneste aktivitet
48 min siden Google Mesh med Switch Af bspeich i Wifi
I dag 15:27 Fejl tastatur Af andys i PC
I dag 14:25 Automatisk Mix Af CMH i Excel
I dag 14:02 Skjulte kolonner kommer frem igen Af LotteP i Excel
I dag 13:55 Dymo Label v.8 fjern symbol Af frem-ad i Andet software


Premium
IBM fortsætter offensiv opkøbsstrategi: Køber en af de største og ældste multicloud-leverandører i USA
IBM opkøber cloud-virksomheden MSP Taos. Det er blot det seneste opkøb fra IBM i jagten på de store cloud-giganter og falder i tråd med IBM's offensive hybrid cloud-strategi.
Computerworld
IBM vinder millionaftale om nyt toldsystem
Skatteforvaltningen har tegnet en tiårig kontrakt IBM om levering af det sidste it-system til i en omfattende systemudskiftning i toldsystemerne og som først forventes afsluttet i 2025. Se alle detaljerne her.
CIO
Podcast: Hos Viking Life-Saving Equipment er it gået fra at være backend til at være noget, som kunderne spørger aktivt efter
Podcast, The Digital Edge: Viking leverer en stadig større del af deres produkt som en tjeneste. Som en del af tjenesten tager Viking ansvar for sikkerheden ved at levere, dokumentere og vedligeholde det nødvendige sikkerhedsudstyr. Hør hvordan Henrik Balslev senior digital director hos Viking har løftet den opgave.
Job & Karriere
Microsoft i kæmpe dansk satsning - åbner tre store datacentre i Danmark
Microsoft lancerer kæmpe satsning fra hovedkvarteret i Lyngby. Selskabet åbner tre store bæredygtige datacentre på Sjælland.
White paper
Gratis whitepaper: Hvad er EDI, og hvordan kan det styrke min forretning?
Overvejer du EDI, og ønsker du at undersøge, om EDI er den rette investering for din virksomhed? Har en af dine kunder eller leverandører for nyligt bedt dig om at udveksle elektroniske dokumenter (EDI)? Så hent dette whitepaper og få et overblik over, hvad EDI er, og hvilke fordele producenter og grossister som dig kan se frem til, når du investerer i EDI til din forretning.