Avatar billede Juniormester
19. juli 2021 - 09:49 Der er 6 kommentarer og
1 løsning

Udregning af point på baggrund af alder og aktivitetsniveau

Hej - håber I kan/vil hjælpe :)

Præmissen er følgende:

A1: Nr.
B1: Fornavn
C1: Efternavn
D1: Fødselsår
F1: Alder pr. 1. januar sidste kalenderår
G1 Gold/Gruppe
H1: Aktivitetstimer
I1: Point

Jeg skal bruge en formel som udregner et antal point (I1) på baggrund af en persons alder (F1) og aktivitetstimer (H1).

- En person i aldersgruppen 0-5 år skal uanset aktivitetsniveau have 1 point.
- En person i aldersgruppen 19-24 år skal uanset aktivitetsniveau have 2 point.
- En person i aldersgruppen 6-18 år som har ml 1-40 aktivitetstimer skal have 3 point, ml. 41-80 aktivitetstimer skal have 6 point og mere end 80 timers aktivitetstimer skal have 9 point.

Jeg er udfordret på HVIS(OG(ELLER i den forbindelse, men måske I kan komme med et godt bud? :)



Jeg leder efter en formel som gør, følgende i I1 (Point):

Hvis en person er i aldersgruppen 6-18 år (
Avatar billede Juniormester
19. juli 2021 - 09:56 #1
De sidste to linjer skal blot ignoreres :)
Avatar billede claes57 Ekspert
19. juli 2021 - 10:58 #2
tager det fra en ende af - den første hvis udelukke nogle - og så kan du klare dig med
=HVIS(F1<6;1;HVIS(F1>18;2;HVIS(H1<41;3;HVIS(H1<81;6;9))))
så alle over 18 år får 2 point - også hvis der skulle være en på 75 med.
Avatar billede Juniormester
19. juli 2021 - 11:39 #3
Det ser ud til at virke :)

Jeg glemte, at alle på 25 og derover skal have 0 point - kan du tilføje det?
Avatar billede Juniormester
19. juli 2021 - 11:41 #4
Når jeg bruger formlen, så står der automatisk "2" i kolonne "I" (point), selvom kolonne "F" (alder) ikke er udfyldt..
Avatar billede claes57 Ekspert
19. juli 2021 - 12:04 #5
=HVIS(F1="";"";(HVIS(F1>25;0;HVIS(F1<6;1;HVIS(F1>18;2;HVIS(H1<41;3;HVIS(H1<81;6;9)))))))

(det er på en linje)
jeg sorterer først de tomme fra, og sætter så dem over 25 til 0 - resten er som før
Avatar billede Juniormester
19. juli 2021 - 14:07 #6
Tak for hjælpen.
Det er mit første opslag herinde og jeg ved ikke, hvordan man giver point (og om jeg overhovedet har nogen at give?) :)
Avatar billede claes57 Ekspert
19. juli 2021 - 16:38 #7
der er ikke point her - bare accepter et svar, og det er fint.
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Her er de bedste antivirus-programmer til Windows 10 lige nu (plus dem du nokskal holde dig fra)
Syv antivirus-programmer ligger helt i top, når det gælder om at levere solid antivirus-beskyttelse til Windows 10. Se listen over de bedste antivirus-programmer lige nu
Computerworld
Tysk unicorn-app stormer ind på det danske marked: Vil levere dine dagligvare-indkøb på 10 minutter
Gorillas er en app-drevet udbringningstjeneste, der er blevet kaldt for Europas hurtigstvoksende startup. Tjenesten vil nu udbringe dagligvare til danskerne inden for 10 minutter.
CIO
Årets CIO 2021: Nu skal Danmarks dygtigste CIO findes - er det dig? Eller kender du en, du vil indstille?
Det er den mest eftertragtede titel for danske it-chefer og CIO'er, der er på spil, når Årets CIO kåres 16. september 2021. Søg selv eller prik til en, som du kender - og læs mere om prisen her.
Job & Karriere
Så meget kan du tjene: Disse stillinger giver den højeste løn i den danske it-branche lige nu
Du skal have ledelsesansvar, hvis du vil helt tops i lønhierakiet i den danske it-branche, viser nye tal. Se hvor meget du kan tjene i de stillinger i it-branchen, der giver den højeste månedsløn lige nu.
White paper
Er din forretning og jeres Dynamics 365 klar til løbende opdateringer?
Hyppige opdateringer af din Dynamics 365 sikrer hurtig adgang til nyeste funktioner og opdateringer. Men metoden rummer også risici. Læs her, hvordan du minimerer dem.