Avatar billede boro23 Seniormester
08. november 2021 - 14:07 Der er 3 kommentarer og
1 løsning

Hjælp til formel

Jeg skal bruge en formel, der kan finde disse kriterier i en tekststreng. Er der en venlig sjæl der hjælpe? :-)
Hvis en af nedenstående kriterier findes i tekststrengen (KOL. F), skal kriteriet returneres i KOL. J

Kriterier » MAP, VAC, BOX, CraG, CraS
Avatar billede jens48 Ekspert
08. november 2021 - 14:37 #1
Denne formel vil kunne klare det:

=IFERROR(IF(SEARCH("MAP";F1);"MAP";"");"")&IFERROR(IF(SEARCH("VAC";F1);"VAC";"");"")&IFERROR(IF(SEARCH("BOX";F1);"BOX";"");"")&IFERROR(IF(SEARCH("CraG";F1);"CraG";"");"")&IFERROR(IF(SEARCH("CraS";F1);"CraS";"");"")

På dansk:
=HVIS.FEJL(HVIS(SØG("MAP";F1);"MAP";"");"")&HVIS.FEJL(HVIS(SØG("VAC";F1);"VAC";"");"")&HVIS.FEJL(HVIS(SØG("BOX";F1);"BOX";"");"")&HVIS.FEJL(HVIS(SØG("CraG";F1);"CraG";"");"")&HVIS.FEJL(HVIS(SØG("CraS";F1);"CraS";"");"")
Avatar billede xl-Enthusiast Ekspert
08. november 2021 - 14:58 #2
Eller med MAP, VAC, BOX, CraG og CraS i F2:F6

=SUMPRODUCT(--ISNUMBER(FIND($F$2:$F$6;F1)))>0

dansk
=SUMPRODUKT(--ER.TAL(FIND($F$2:$F$6;B2)))>0

FIND skelner mellem store og små bogstaver, det gør SØG ikke.
Avatar billede xl-Enthusiast Ekspert
08. november 2021 - 15:01 #3
Den danske udgave skulle have været:
=SUMPRODUKT(--ER.TAL(FIND($F$2:$F$6;F1)))>0
Avatar billede boro23 Seniormester
09. november 2021 - 07:55 #4
1000 tak for Jeres løsninger, jeg går med jens48, da den gør lige hvad den skal, trods den store formel. xl-Enthusiast din formel returner kun Sand eller falsk, ellers en dejlig kort formel.
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Sådan tager top-CIO Pernille Geneser livtag med 40 år gamle it-systemer i Stark Group med 10.000 medarbejdere