Avatar billede AGoodCocktail Juniormester
05. maj 2022 - 12:58 Der er 2 kommentarer og
2 løsninger

Ugenr i række med givent år ud for - 52 uger vs 53 uger

Hej

Jeg skal have lavet et ark, der automatisk plusser en uge til ovenstående celle, men når alle uger i året er gået, så skal den starte forfra med uge 1.

Den første række indtastes manuelt og så skal de efterfølgende celler udfyldes automatisk. 

Det havde været nemt nok, hvis der altid var 52 uger på et år, så kunne man gøre sådan her:

Uge        År   
4        2022    Manuelt indtastet
5        2022   
6        2022   
7        2022   
osv.        osv.   
50        2022   
51        2022   
52        2022   
1        2023   
2        2023   
3        2023   

Formel i A3
=HVIS(A2<53;HVIS(A2=52;1;A2+1))

Formel i B3
=HVIS(A2+1=53;B2+1;B2)

Men når der indimellem er 53 uger på et år, kan jeg ikke lige kringle formlen.

Jeg tænkte man kunne lave noget L-opslag med de år, der har 53 uger:

2026
2032
2037
2043
2048
2054
2060
2065

Men jeg kan ikke få det til at virke.

Så hvis året i kolonne B er en del af den kolonne med 53 uger, så vil der fremgå 53 rækker med det givne år og hvis ikke vil der fremgå 52 uger.

I 2026 vil der derfor være 53 rækker før det nye år starter.

I er altid så skarpe, så der er sikkert en nemmere måde. I så fald, kom endelig med den :)

Jeg ønsker dog ikke matrix formler.

Håber i kan hjælpe.
Avatar billede jens48 Ekspert
05. maj 2022 - 13:45 #1
Lav en separat kolonne (for eksempel A med en dato i uge 4 i 2022. Læg 7 til nedefter og brug denne formel til uge nummer:
=ISOWEEKNUM(A2)
På dansk:
=ISOUGE.NR(A2)
og denne formel til år:
=YEAR(A2)
På dansk:
=ÅR(A2)
Avatar billede jens48 Ekspert
05. maj 2022 - 13:55 #2
For at få det til at fungere korrekt bør du indtaste datoen for torsdag i den ønskede uge
Avatar billede xl-Enthusiast Ekspert
05. maj 2022 - 16:25 #3
Hvis du har adgang til funktionen SEQUENCE (på dansk SEKVENS)

Med et givent år i A1:

=IF(ISOWEEKNUM(DATE( $A$1;12;28))=53;SEQUENCE(53);SEQUENCE(52))

dansk

=HVIS(ISOUGE.NR(DATO( $A$1;12;28))=53;SEKVENS(53);SEKVENS(52))
Avatar billede AGoodCocktail Juniormester
05. maj 2022 - 16:46 #4
Det virker.

Mange tak :)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
10 gratis artikler: Få gode råd fra Danmarks bedste it-ledere