Renek Novice
14. januar 2013 - 11:15 Der er 6 kommentarer og
1 løsning

Formel til betinget summering

Jeg kan ikke finde ud at få Excel til kun at summere en række tal når datoen er ens via en "magisk formel" som jeg blot kan trække ned.

http://screencast.com/t/W9UnRy2KHji

Normalt ville jeg løse det via en pivottabel, men jeg har brug for at kunne opdatere en lang række ark hurtigt samt slå op i dem, så jeg er ikke sikker på at pivot er den bedste løsning?
finb Mester
14. januar 2013 - 12:59 #1
Skal du ikke bare have en 
=sum.hvis
med dato i gåseøjne
"2013-01-14"
eller
""2013-01-14""
?
Renek Novice
14. januar 2013 - 13:04 #2
Kan du skrive det som formlen ville skulle se ud? Jeg er ikke super ferm til det her :/
natkatten Mester
14. januar 2013 - 15:18 #3
Hmm, jeg ville ikke hardkode datoen ind i formlen, men løse det ved hjælp af f.eks. denne SUMPRODUKT-formel:

=SUMPRODUKT(($B$3:$B$100=$E3)*($C$3:$C$100))

Dine første datoer er her i kolonne B. De unikke datoer er i kolonne E. Værdierne, der skal summeres er i kolonne C.

Se mere:

http://gupl.dk/690108/
Renek Novice
15. januar 2013 - 07:43 #4
Fantastisk - det virker! Tak :)
Renek Novice
15. januar 2013 - 07:44 #5
Kan du ikke skrive igen som svar "natkatten", så jeg kan give dig point.
natkatten Mester
15. januar 2013 - 10:02 #6
Her er et svar

/natkatten
natkatten Mester
15. januar 2013 - 10:03 #7
Og nu som svar
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Denne programmør har fundet det perfekte våben mod Windows-svindlere og irriterende telefon-sælgere
Programmøren Roger Anderson har bygget en robothær, der bliver sendt i krig mod svindlere og irriterende telefonsælgere.
CIO
Sikkerhedsfolk: Sådan vil ransomware-plagen udvikle sig (det bliver meget værre)
Vi har kun set begyndelsen på ransomware-plagen, vurderer sikkerhedsfolk. Næste fase kan blive total nedlukning af hele fabrikker, anlæg og organisationer. Og hvad gør vi så?
Comon
Sådan installerer du Googles bil-system, Android Auto, på din smartphone
Android Auto har indtil nu krævet en bil med indbygget computer med touchskærm for at kunne fungere. Nu kan du installere systemet på din Android-telefon og benytte den som bil-computer og navigations-system. Se her, hvordan du gør.
Channelworld
Tidligere Atea-boss Claus Hougesen er færdig som direktør i 3A-it: Her er årsagen
Claus Hougesen er stoppet som administrerende direktør for 3A-it og har i stedet overladt posten til Preben Jensen, der ligeledes har en fortid hos Atea.
White paper
Hyperconverged infrastructure - Optimer datacentret med den enkleste og mest fremtidssikrede løsning
Mere integration betyder mindre arbejde for datacenteradministratorer - Læs hvordan i dette white paper. Dette white paper er skrevet af Computerworld for SEC Datacom