Avatar billede Kluddermor Juniormester
30. juni 2017 - 21:50 Der er 13 kommentarer og
1 løsning

Murphy har været der igen igen. Windows vil ikke boote.

Hej Eksperter

Murphys lov er trådt i kraft for 117 gang for mig :(

Jeg ville bare sætte en 120 Gb SSD i min anden PC og så gik det galt. Her er forløbet. Jeg havde en SSD fra en bærbar, hvor blæseren var gået død.
-------------------------------------------------------------------------------------------
Jeg sætter disken i på en ledig sata port.

Starter PC'en. BIOS tror den skal boote fra den "nye" SSD. (Den indeholder styresystemet fra den bærbare) Den vil starte system repair og jeg bliver klar over at den booter fra den forkerte disk.

Jeg piller den "nye" SSD fra igen og genstarter PC'en. Alt starter som det skal.

I windows sætter jeg SSD'en til igen og den kommer frem som H:

Jeg formaterer H:

Jeg opretter mapper og overfører filer til det nye H:

Jeg slukker PC'en

I dag vil PC'en ikke starte. Den bliver ved med at sige "reboot and select proper boot device or insert boot media"
----------------------------------------------------------------------------------------
Jeg har prøvet med en windows 10 recovery disc og bedt den gentagne gange om at lave startup repair. Det virker ikke.

Jeg har på fornemmelsen, at det er den ekstra systempartition på den "nye" SSD, som har kuppet opstarten. Den fik jeg selvfølgelig ikke formateret. Den må have slettet MBR på den oprindelige SSD og nu vil PC ikke starte.

Jeg har tjekket i Command promt, at alle mapper stadig er der på min oprindelige SSD.

Hvordan får jeg liv i maskinen igen?
Avatar billede Kluddermor Juniormester
30. juni 2017 - 21:52 #1
I BIOS har jeg i øvrigt sat den til at boote fra den oprindelige SSD.
Avatar billede valby Ekspert
30. juni 2017 - 22:08 #2
Er du sikker på, at du med W10 kører med MBR og ikke GPT? Er det en opdatering?
Under alle omstændigheder, prøv under boot, så snart maskinens logo viser sig, så at tappe med tast F12. Så skulle der komme en menu frem, hvor du kan vælge den disk som indeholder operativsystemet.
Avatar billede valby Ekspert
30. juni 2017 - 22:25 #3
F12 virker fint på min W8.1, men nu har jeg lige prøvet på min bærbare (Asus) med W10, men der virkede det ikke. Så det råd er måske ikke brugbart?
Avatar billede Kluddermor Juniormester
30. juni 2017 - 23:00 #4
Hej Valby

På min skal jeg trykke F8 for at få bootmenu frem. Men selvom jeg vælger min Intel SSD, så får jeg samme besked.

Jeg har dog googlet lidt og leget med DISKPART. Jeg satte min partition med windows til at være "active"

Så skrev den BOOTMGR missing ved næste genstart

Derefter prøvede jeg endnu en ting fra Googles gemmer i command promt
Bootrec /fixboot

Den skrev straks at kommandoen var gennemført. (lidt for hurtigt tror jeg, eftersom artiklen sagde at der ville gå lidt tid før den var færdig med fixboot kommandoen.

ved genstart skriver den nu, at enheden ikke indeholder et styresystem.
Avatar billede valby Ekspert
01. juli 2017 - 01:42 #5
Hvis du er interesseret kan jeg sende dig en Iso med MiniTool.
Den er på 136MB, og så må jeg lige finde ud af, hvordan man best sender den.
Avatar billede 220661 Ekspert
01. juli 2017 - 06:36 #6
Hvis den skriver Bootmgr missing, kører den så ikke MBR Valby1?
Avatar billede 220661 Ekspert
01. juli 2017 - 06:41 #7
@kludddermor: Slukker du computeren ned midt i startforløbet hvor den starter op på den forkerte disk?

Hvis det kun er MBR den mangler for at starte op kan den genskrives til ssd disken med kommandoprompt:
http://www.thewindowsclub.com/repair-master-boot-record-mbr-windows
Avatar billede valby Ekspert
01. juli 2017 - 12:47 #8
#6 Jo sådan læser jeg også #4, og det er derfor jeg foreslår at sende en MiniTool Iso .Så kan man jo,med Rufus, lave en bootbar USB stick.
Når man booter på den, får man det normale interface og kan forsøge med Wizard at gendanne partitionstabellen.
Avatar billede valby Ekspert
01. juli 2017 - 13:02 #9
Ps. Så vidt jeg kan se, kan man ikke længere, i MiniTool, lave et Bootable Media, det kræver købe programmet. Ellers var det selvfølgelig nemmere.
Avatar billede ink Ekspert
01. juli 2017 - 16:51 #10
Da du kører Windows10, så kunne du jo geninstallere helt fra bunden. Jeg ved godt det kræver geninstallation af dine programmer, men det giver en dejlig ren maskine.
Download media creation tool fra Microsoft samt relevant udgave af Windows10.
Forstår at alle dine filer er reddet og nu ligger hvor de skal.
Avatar billede Kluddermor Juniormester
01. juli 2017 - 17:15 #11
Tak for kommentarer. Jeg er lige nu "fanget" på forlænget weekend i Sverige og kan ikke ikke komme til Pc'en før tirsdag.
@#7 Jeg genstartede den mens den var i gang med noget på den forkerte disk.

Jeg kan se at hele mappestrukturen er intakt på drevet, så jeg går ud fra at det er MBR der er det eneste problem. Det skal siges at det først var efter jeg havde brugt fixboot at den skrev bootmgr messing.

Der ligger egentligt ikke noget på drevet, der mistes ved en reinstallation af win10. Det meste ligger på et HDD raid drev. Der er dog et hav af programmer der kræver reinstallation for at virke igen og genopsætning, så jeg skal lige give MBR en chance mere eller to.
Avatar billede Kluddermor Juniormester
04. juli 2017 - 16:33 #12
Så virker den igen. :)

Jeg gjorde som der stod i opskriften på #7 link

bootrec /RebuildBcd
bootrec /fixMbr
bootrec /fixboot

bootrec /rebuildbcd var tilsyneladende den der gjorde, at PC'en blev klar over, at der fandtes et styresystem et sted.

Dog virkede PC'en ikke af den grund, men efter en fejlslået genstart, så kunne jeg bruge win10s egen startup repair. Nu kunne jeg vælge, at det var win10 jeg ville lave startup repair på, og så virkede den bagefter.

Nu har jeg lige indsat den ekstra SSD.  Jeg fjerner nu den partition der var reserveret til systemet på den gamle bærbare, genstarter og krydser fingre.

Tak for hjælpen :)
Avatar billede milter Ekspert
04. juli 2017 - 16:59 #13
Hvis du vil checke, om styresystemet fra den gamle SSD stadig rumsterer på din computer, kan du checke det med hjælp fra linket herunder. Start med den, der hedder "Option Three: To Choose Default OS in System Configuration (msconfig)"

https://www.tenforums.com/tutorials/21934-choose-default-operating-system-run-startup-windows-10-a.html
Avatar billede 220661 Ekspert
04. juli 2017 - 18:54 #14
#12 Velbekomme :-)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Stort CIO-interview: Lemvigh-Müllers milliard-omsætning er blevet digital