dartlykke Novice
09. november 2018 - 12:40 Der er 5 kommentarer og
1 løsning

Søg i anden fane!

Jeg har lidt problemer med at få en "løkke" til at fungere håber i kunne have lyst til at hjælpe :)

Ark 1:
I kolonne N6:N28 får jeg givet en værdi fra 1-22 forhold til hvilken værdi der er højest i M6:M28 og så i C6:C28 Angiver jeg et navn jeg gerne vil have overført til Ark 2

så det jeg forsøger som ikke virker er i Ark 2:
A1=1

=LOPSLAG(A1;'Ark 1!$C$6:$N$26;1;FALSK)

kan i hjælpe mig... på forhånd tak.
MVH Jesper
kim1a Ekspert
09. november 2018 - 13:22 #1
Du skal slå op i kolonne N, så du bliver enten nødt til at have C kolonnen gentaget efter N (da lopslag kun kan slå op og returnere efter opslagskolonnen, eller også skal du ud i indeks sammenlign formel - søg evt. på Google for at forstå.

Så din formel skal hedde:
=LOPSLAG(A1;'Ark 1!$N$6:$O$26;2;FALSK)
Hvor O i mit teoretiske eksempel er en kopi af kolonne C.
dartlykke Novice
09. november 2018 - 13:35 #2
Men kan du ikke gå ind og fortælle den at den skal tælle bagud i forhold til N6:N28?

Jeg kan godt få den til at give det rette resultat men så gerne at jeg ikke skulle gentage mig selv i mit excel ark! :D
kim1a Ekspert
09. november 2018 - 13:54 #3
Nej, lopslag kan ikke tælle bagud, og den vil altid lede efter referencen du beder om i første kolonne du angiver, så i dit eksempel vil den lede efter A1 i Kolonne N.

Du skal bruge en kombination af indeks og sammenlign hvis du vil arbejde bagud.
kim1a Ekspert
09. november 2018 - 13:54 #4
Hov undskyld, dit eksempel vil den lede i kolonne C
ebea Ekspert
09. november 2018 - 14:07 #5
Ved ikke helt, om jeg har forstået dig korrekt. Men prøv med denne formel, hvis det er navnet du skal returnere, i forhold til tallet i A1.
=INDEKS(C6:C26;SAMMENLIGN('Ark2'!A1;'Ark1'!N6:N26;0))
dartlykke Novice
12. november 2018 - 08:29 #6
Jeg fik det til at virke ved at flytte min Ark1 N6:N26 til A6:A26 så virker det hele du fik mig på rette spor Kim1a.
Du får den her, da det var din viden der fik det til at fungere oppe i mit hoved :D jeg takker...
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
"Det kan godt være, at du tjener flere penge i det private, men du har ikke det samme fokus på faglighed, sammenhold og netværk som i det offentlige."
"Når først noget fungerer i det offentlige, så går man all in, og det kan man også mærke for tiden i forhold til ny teknologi og digitalisering i kommunerne."
CIO
Tech fra Toppen: Tim Vang får hastigheden op og de rigtige idéer frem med Googles pretotyping
Tech fra Toppen: Tim Vang får ideerne frem og hastigheden op ved konstant at tænke små overskuelige eksperimenter ind idéprocessen. Metoden hedder pretotyping og stammer fra Google. Lær meget mere om, hvordan du kan bruge værktøjet her.
Job & Karriere
Efter blodrødt regnskab: Nu fyrer Atea 20 medarbejdere i Danmark
Atea fyrer nu 20 medarbejdere. Det sker som en direkte konsekvens af, at den danske forretning er under pres, oplyser selskabets direktør.
White paper
Gratis e-bog: Mister du pusten på BI-bjergetapen? Tag den lige vej i stedet!
Denne e-bog er relevant for dig der sidder i en virksomhed, der allerede arbejder med Dynamics 365 for Finance & Operations, eller som overvejer at få det. Det er din genvej til at komme tilbage på BI-motorvejen, hurtigt og på den rigtige måde. Du finder ud af hvordan du kommer ud over bumpene og uden om hullerne på bjergvejen med CBI Plugin, så du igen kommer tilbage på motorvejen og kan køre direkte mod målet. Læs videre og bliv klogere på, hvordan du kommer over – eller helt undgår – de største bump på bjergetapen.