Avatar billede KSN Mester
23. september 2019 - 19:43 Der er 12 kommentarer og
1 løsning

Hjælp til HVIS formel

Skal have lavet en HVIS formel, det er første gang og kan ikke lige finde svar på Google.
Jeg skriver nok bare formelen i forkert rækkefølge

Det skal lyde sådan
=HVIS(A13>50:Ark1!E22)

Altså HVIS A13 er større end 50 skal Ark1 E22 trækkes fra og ellers skal den bare gå i 0
Avatar billede Jan Hansen Ekspert
23. september 2019 - 20:08 #1
=HVIS(A13>50;Ark1!E22)
Avatar billede KSN Mester
23. september 2019 - 20:22 #2
1. Det giver ikke det rigtige resultat.

Hvis den er under 50 skriver den falsk og lige meget hvor meget den er over 50 giver den resultatet 50.

Men jeg har så også en ændring til formlen, den skal hedde:
Altså HVIS A13 er større end Ark1 E23 skal Ark1 E22 trækkes fra og ellers skal den bare gå i 0
Avatar billede Jan Hansen Ekspert
23. september 2019 - 20:40 #3
=Hvis(A13>'Ark1'!E23;'Ark1'!E23-'Ark1'!E22;0)

Cellen formateres Standart eller tal
Avatar billede store-morten Ekspert
23. september 2019 - 21:15 #4
Mangler vel bare et 0

=HVIS(A13>50;'Ark1'!E22;0)
Avatar billede store-morten Ekspert
23. september 2019 - 21:23 #5
=HVIS(A13>'Ark1'!E23;'Ark1'!E22;0)

Altså HVIS A13 er større end Ark1 E23 skal Ark1 E22 trækkes fra (fra hvad?) og ellers skal den bare gå i 0
Avatar billede KSN Mester
23. september 2019 - 21:36 #6
=HVIS(A13>'Ark1'!E22;'Ark1'!E22;0) Virker egentlig men den glemmer at trække E22 fra.

Hvis A13 er under E22, så skriver den 0, men hvis A13 er over, så skriver den bare det tal der står i E22 og trækker det ikke fra


Ved godt jeg roder lidt rundt i det, men vil prøve at forklare.

I nogle kommuner medregner men ikke x antal m² for garager, carporte, skure osv.
Så her får man et fradrag i sin bebyggelsesprocent.

Så lad os sige at E22 (Hvor mange gratis m² der er. I det her tilfælde 50m²)

I Ark2 A13 har den lagt Skur 5m², carport 40m² og overdækning 10m² sammen.
Det giver i alt 55m²
Men E22 (50m²) skal trækkes fra og det er så kun de resterende 5m² som skal medregnes i bebyggelsen

Jeg skal have den til at trække E22 fra, og give mig de overskydende m², men kun hvis den overstiger sig selv (E22)
Avatar billede KSN Mester
23. september 2019 - 21:39 #7
Kan lige tilføjes at denne
=Hvis(A13>'Ark1'!E22;'Ark1'!E22-'Ark1'!E22;0)

Skriver 0 lige meget om den er over eller under det tilladte
Avatar billede Jan Hansen Ekspert
23. september 2019 - 21:42 #8
=Hvis(A13>'Ark1'!E22;A13-'Ark1'!E22;0)
Avatar billede store-morten Ekspert
23. september 2019 - 21:43 #9
Ja, nu roder du hvis rundt i det ;-)

Du bruger kun E22

Hvis A13>E22 så 0
ellers E22-E22 giver jo også 0
Avatar billede KSN Mester
23. september 2019 - 21:47 #10
Tak for hjælpen begge to.
Jan Hansen du fangede den og ved godt jeg fik byttet lidt rundt på det hele.
Avatar billede store-morten Ekspert
23. september 2019 - 21:47 #11
=HVIS(A13>'Ark1'!E22;     Hvad skal der regnes på her?      ;0)
Avatar billede KSN Mester
23. september 2019 - 22:14 #12
Morten:
(Eksempler)
Hvis A13 (50) er større end E22 (40) skal E22 trækkes fra. I det her tilfælde = 10
Hvis A13 (50) er mindre end E22 (60) skal E22 ikke trækkes fra. = 0
Avatar billede store-morten Ekspert
23. september 2019 - 22:51 #13
Jan´s formel virke vel?

Du skriver:
Hvis A13 (50) er større end E22 (40) skal E22 trækkes fra. I det her tilfælde = 10
OK.
Hvis A13 (50) er mindre end E22 (60) skal E22 ikke trækkes fra. = 0
Ikke OK. 50 - ingen ting = 50

Du mener:
Hvis A13 (50) er mindre end E22 (60) = 0
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Sådan tager top-CIO Pernille Geneser livtag med 40 år gamle it-systemer i Stark Group med 10.000 medarbejdere