Avatar billede AGoodCocktail Novice
14. september 2021 - 17:40 Der er 6 kommentarer

Find pris på vare baseret på nyeste dato

Hej

Jeg kommer ind i et lille dilemma.

Vi har løbende fået nye priser på samme varenr.

Jeg vil gerne have en formel, der finder prisen på varen baseret på den nyeste dato. De gamle priser på det varenr gerne skulle være tomme.

Varenr    Dato            Pris      Fundet pris
11111    15.01.2021    5,5           
22222    30.04.2021    7,15      7,15
11111    30.01.2021    6,7      6,7
33333    01.01.2021    10,2    
33333    15.03.2021    11,7    
55555    15.05.2021    3,1      3,1
44444    01.07.2021    15,6      15,6
33333    30.06.2021    12,9      12,9

Håber i kan hjælpe.
Avatar billede kim1a Ekspert
14. september 2021 - 18:31 #1
Mit forslag:
En støttekolonne med kombination af dato og varenummer, derefter en maxifs sætning til at definere nyeste dato for hver enkelt produkt og slutteligt et opslag på kombinationen af den fundne dato og varenummer.
Avatar billede ebea Ekspert
14. september 2021 - 19:30 #2
Prøv med:  =SLÅ.OP(2;1/(A4:A11=C1);C4:C11)

vare nr. du søger, i C1
Avatar billede xl-Enthusiast Ekspert
15. september 2021 - 09:46 #3
Eller (med opslagsværdi i A1 og data i A2:C9), hvis du har adgang til funktionen XOPSLAG:

=XOPSLAG(A1;A2:A9;C2:C9;;;-1)
Avatar billede kim1a Ekspert
15. september 2021 - 10:20 #4
#3 forudsætter det ikke at datoerne er sorteret?
Avatar billede jens48 Ekspert
15. september 2021 - 10:51 #5
Prøv med:

=HVIS(MAKS(($A$4:$A$11=A4)*$B$4:$B$11)=B4;C4;"")
Avatar billede xl-Enthusiast Ekspert
15. september 2021 - 10:53 #6
#4

Jo. I den situation, brug: =MAKSHVISER(C2:C9;A2:A9;A1)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Ny rekord: Her er elbilen med den længste rækkevidde / Få timer til at Apple er klar med ny iOS 15 / Teslas vilde model S Plaid sætter fantomtid på hæderkronet bane