13. oktober 2021 - 22:23 Der er 4 kommentarer og
3 løsninger

summering af et felt

Hej

Jeg leder efter en funktion, der kan summe et tal i et felt. for eksempel, hvis jeg indtaster 1977 i et felt, skal funktionen kunne summere tallene til 24. er det muligt i Excel?
Har ikke selv været ude for lignende øvelse før, nu blev jeg stillet det spørgsmål og er nysgerrig efter at finde ud af det. Håber nogle af jer der kan give et tip!

på forhånd tak
Avatar billede acore Ekspert
14. oktober 2021 - 08:52 #1
Med 1977 i A2:

=SUMPRODUCT(1*MID(A2;ROW(INDIRECT("1:"&LEN(A2)));1))

fra https://www.excelhow.net/how-to-sum-all-digits-in-a-cell-in-excel.html
14. oktober 2021 - 10:38 #2
Mange tak, det er fantastisk,som det virker!
Af god grund fungerede funktionen ikke i en dansk version af Excel. så forsøgte jeg at oversætte funktionen ved hjælp af "Function Translator", men det fungerede heller ikke så godt.
Men så fik jeg installeret engelsk i Excel og derefter ændret sproget til engelsk, så det virkede funktionen perfekt.
Tak igen for hjælpen :)
Avatar billede acore Ekspert
14. oktober 2021 - 11:27 #3
Cool - tak for feedback
Avatar billede Erik K Professor
14. oktober 2021 - 18:15 #4
I Excel i dansk version er formlen:

=SUMPRODUKT(1*MIDT(A2;RÆKKE(INDIREKTE("1:"&LÆNGDE(A2)));1))
14. oktober 2021 - 21:12 #5
Perfekt mange tak. det virker bare.
Jeg kan se, at det er en direkte oversættelse af funktionen, og der var ikke behov for mere. Dette er et godt råd for anden gang. Jeg behøver ikke tænke indviklet, når løsningen er enkel.
Avatar billede Erik K Professor
15. oktober 2021 - 01:55 #6
Oversættelser er ikke altid så lige til.
Du kan finde de fleste oversættelser fra engelske til danske excel funktioner på denne hjemmeside:

dk.excelfunctions.eu
15. oktober 2021 - 10:17 #7
Det er en rigtig god og nyttig liste, tusind tak!
Jeg har gemt hjemmesiden i min favoritter :)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester