Avatar billede casablanca Mester
23. januar 2022 - 12:06 Der er 9 kommentarer

efter dsm opdatering problemer med plex

Hej
Der har lige været en opdatering af synology dsm. Det har nu medført følgende:
På min mobil kan jeg se mit plex-indhold (ligger på min synology nas) når jeg har mobilen på mit wifi. Men slår jeg wifi af og kører på mobilnetværk, forsvinder plexindholdet.

På min pc kan jeg ikke længere se mit plexindhold. Dvs. når jeg går ind på browseren via plex.com og logger ind.

Er der en der kan hjælpe mig?
Avatar billede Bruce Novice
23. januar 2022 - 13:16 #1
Meld dig ind i denne gruppe her, så er der hjælp at hente

https://www.facebook.com/groups/SynologyDK
Avatar billede ole_madsen Ekspert
23. januar 2022 - 18:08 #2
Har du opgraderet fra DSM 6.x til 7.x? - så var der nogle ting du skulle have forberedt. Der ligger ret grundige guides på Plex´ forskellige brugerfora. Se evt. den tidligere tråd om emnet her på eksperten: https://www.computerworld.dk/eksperten/spm/1038215
Avatar billede casablanca Mester
24. januar 2022 - 00:15 #3
Bruce: Tak, det vil jeg gøre.

Ole Madsen: Nej, jeg har lavet en opgradering fra 7,xx til den nyeste. Jeg havde masser af problemer da jeg opgraderede til 7, men de blev løst. Nu har jeg igen problemer efter en af deres opgraderinger.
Avatar billede casablanca Mester
24. januar 2022 - 00:18 #4
Ole madsen: Den tråd du henviser til er faktisk min egen. Jeg fik løst problemet fra synologys support, men det jeg sidder med nu, er som jeg beskriver det i min problembeskrivelse. Det er rent ud sagt pisse frustrerende, at man sidder med problemer efter hver eneste dsm-opdatering fra synology. Alting fungerede ellers fint.
Avatar billede ole_madsen Ekspert
24. januar 2022 - 08:45 #5
:-) Det kunne jeg da også bare have set efter... - nuvel, det har så givet anledning til at læse dit ny spørgsmål en gang til.

På mig lyder det kort og godt som om det virker på LAN, men ikke på WAN, altså et netværksproblem, og ikke problem ved PLEX eller Synology NAS´en.

Jeg har haft mit kørende uden problemer, og har også opdateret løbende, både PLEX og DSM.

Jeg har selv lavet port-forwarding i min router - PLEX bruger 32400. Den er forwarded fra WAN til min Synology NAS på LAN. Jeg ved at PLEX kan håndtere de fleste miljøer uden denne port-forwarding, men skal man være sikker på at kunne køre, bør man lave den. Det ved jeg ikke om du har?

Der er beskrevet lidt mere hos PLEX her: https://support.plex.tv/articles/200931138-troubleshooting-remote-access/

Artiklen dækker ikke kun port-forwarding, men også anden generel troubleshooting.
Avatar billede casablanca Mester
24. januar 2022 - 10:54 #6
Ole Madsen, jeg får en ven til at kigge på det om et par uger, når jeg er hjemme igen. Jeg kan ikke rigtig se mig ud af det selv. Sidst jeg lavede opdatering fra 6 til 7, var der kæmpe problemer med også plex, men jeg fik det tilsidst op at køre. Denne gang har jeg ingen anelse. Jeg ved bare, at jeg stopper med alle de opdateringer nu. De smadrer min opsætning hver gang.
Men som nævnt, så skal det her jo fixes. Jeg vender tilbage igen med det, når min kammerat ser på det. Evt. viser jeg ham dit seneste svar. Tak
Avatar billede ole_madsen Ekspert
24. januar 2022 - 11:15 #7
Tja, normalt skal en opdatering jo ikke give problemer... - men det sker en gang imellem.

Ved den store fra DSM 6 til 7 må man næsten forvente at noget går galt, og  af samme årsag ventede jeg selv et halvt årstid, og kunne derfor se massive problemer med PLEX, før jeg selv røg i fælden. Derfor var min egen opdatering uden nedbrud, om end temmelig omstændig.

Mindre opdateringer regner jeg ikke for problemfyldte.. - og har som sagt heller ikke selv opdaget noget.

En risiko ved ikke at opdatere er jo modsat, at man enten bliver så forældet at man ikke er kompatibel med resten af verden, eller at man efterlader sikkerhedshuller...

Så uanset hvad, bør du lade være med at komme for langt bagud...
Avatar billede casablanca Mester
31. januar 2022 - 02:18 #8
Det der med portforwarding har jeg ikke lige tjek på. Den skriver så heller ikke den samme fejlmelding som der står på dit link. Når jeg plugger wifi fra på min mobil og kører mobilnettet, står der, når jeg åbner plex:

No content from your pinned sourcees
Avatar billede ole_madsen Ekspert
31. januar 2022 - 09:05 #9
Fejlbeskeden kommer vist kun, når du er logget på via dit netværk, og tjekker din opsætning. Så kan den selv se at den ikke kan få ekstern adgang.

Og jeg er heller ikke sikker på du vil få beskeden at se via en mobil - det kræver i hvert fald en "full-blown" browser at se alle indstillingerne...

Port forward er noget du sætter i din router. Om nødvendigt må du have din internetudbyder til at hjælpe dig, men de fleste har åbnet for at man kan selv, og har oven i købet guides til hvordan det gøres. Har du din egen router, må du have fat i manualen.

Men opfat routeren som en lille server, der har fået en IP-adresse fra internet-udbyderen. Routerens opgave er nu at lave et netværk på dit LAN, og rute trafikken videre til/fra internettet. Langt de fleste kald foregår FRA dit LAN TIL internettet, og der er derfor åben for langt det meste den vej.

Men hvis du vil have adgang til noget på dit LAN, mens du ikke selv er på LAN, skal du have åbnet i din router, så den ved hvilken enhed på LAN det er du vil have fat på - du har jo kun den ene IP fra internetudbyderen at kontakte - og for routerens vedkommende kunne det jo være enhver enhed på dit LAN der kunne komme et kald til. Du er derfor nødt til at fortælle routeren, at det er din NAS der kommer et kald til.

Men du vil jo ikke have alle kald til at gå til din NAS - dels fordi det sikkerhedsmæssigt ville servere NAS´en for alt og alle på internettet. Dels fordi det ville ødelægge eventuelle andre tjenester du bruger, når dine enheder kalder ud og forventer svar ind.
Og det er derfor man har opfundet "porte" - man kan groft sammenligne med lastbils-portnumre på en fragtcentral. En given lastbil ved at den skal køre til port 8 for at hente varer til en bestemt kunde.
Plex bruger så port nummer 32400, så du skal ind og fortælle din router at trafik til denne port, altid skal videresendes til din NAS.

De fleste routere arbejder med "port forwarding" til IP adresser, så det kræver at din NAS har fast IP adresse. Jeg kører med Google WiFi i øjeblikket, og her kan jeg sætte Googles WiFi til selv at give NAS´en en fast adresse - men du kunne lige så godt definere den fast i selve NAS´en. Bare du husker IKKE at gøre den fast, inden for det adresseområde routeren tildeler automatisk, for da routeren i dette tilfælde ikke ved hvilken fast IP adresse NAS´en har, risikerer du at den tildeler samme adresse til en ny enhed på nettet - og så har du en adressekonflikt.

Så altså:
* fast IP til NAS´en på dit lan.
* Port Forwarding i routeren af  port 32400 til din NAS.

Så burde det virke.
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Årets CIO 2022: Nu skal Danmarks dygtigste CIO findes - er det dig? Eller kender du en, du vil indstille?