Avatar billede rabitjosph Novice
30. april 2022 - 15:20 Der er 2 kommentarer og
1 løsning

Copy formel indtil side aktiv række

Kolonne B er der forskellige tal som skal divideres med 1000000 resultatet skrive i kolonne C, det skal den blive ved til sidste celle med tal i kolonne B
Avatar billede claes57 Ekspert
30. april 2022 - 15:55 #1
i C1 kan du sætte =HVIS(B1="";"";HVIS(ER.TAL(B1);B1/1000000;B1))
og så kopiere den nedad.
Tomme felter i B forbliver tomme i C, og kun tal beregnes, andre (tekst) kopieres bare.
Avatar billede rabitjosph Novice
30. april 2022 - 16:41 #2
Vil gerne det er en makro så den selv gør det til sidste celle i kolonne B,
da det er forskellige datamængde hver dag
Avatar billede jens48 Ekspert
30. april 2022 - 22:03 #3
Prøv med denne makro:

Sub Divider()
Dim LastRow as long
Dim C As Range
LastRow = Range("B" & Cells.Rows.Count).End(xlUp).Row
For Each C In Range("C2:C" & LastRow)
C = C.Offset(0, -1) / 1000000
Next
End Sub
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Stort CIO-interview: Lemvigh-Müllers milliard-omsætning er blevet digital