d4s Novice
14. september 2018 - 22:12 Der er 5 kommentarer og
2 løsninger

beregne antal timer mellem 2 tidspunkter

Jeg får et forkert resultat, når jeg prøver at trække 2 tidspunkter fra hinanden, fordi Excel tror at 22 er en dato og ikke kl. 22, så 22-14:45 bliver til 9:15

Jeg starter med at skille en celle ad, som kan have følgende format:
7-15
eller
14:45-22
eller NF eller BF
Jeg skiller cellen i 2 celler, for at kunne regne arbejdstiden ud:
første tidspunkt:
=HVIS(LÆNGDE(D29)>2;(VENSTRE(D29;FIND("-";D29)-1));D29)
Andet tidspunkt:
=HVIS(LÆNGDE(D29)>2;(HØJRE(D29;LÆNGDE(D29)-FIND("-";D29)));" ")

D29 er naturligvis cellen med tidspunktet.

Min formel er:
=HVIS(LÆNGDE(D29)>2;Q29-P29;" ")
og den trækker så tidspunkterne fra hinanden, hvis der er over 2 tegn i D29.

udfordringen ligger i de formler, der skiller "14:45-22" til 14:45 og 22, da 22 åbenbart skal være 22:00. Jeg har forsøgt med:
=HVIS(LÆNGDE(D29)>2;(HØJRE(D29;LÆNGDE(D29)-FIND("-";D29)))+":00";" ")
som test, men det giver blot "#VÆRDI"
Hvordan kan jeg ændre en celle med et tidspunkt til n:00, hvis længden er under 2? Skal jeg teste på længden af cellen eller teste på om tid(cellen) giver mindre end noget og i så fald lægge ":00" til cellen?

Jeg er kørt helt sur i det og håber at nogen kan knække nødden for mig.
d4s Novice
14. september 2018 - 22:12 #1
cellen kan også indeholde 7-14:45 så ovenstående er blot eksempler :)
Jan Hansen Ekspert
14. september 2018 - 22:29 #2
& istedet for + måske

Jan
ebea Ekspert
14. september 2018 - 23:10 #3
Som udgangspunkt, så er alle tider som excel regner med, angivet som 00:00
Så at begynde at skrive et 2 cifret tal, og så fratrække et tidspunkt angivet som det korrekt tidsangivelse 00:00 skal gå galt.
Så hvis du har celler med tal, så er du nødt til enten at konvertere disse, eller ændre dine tidsangivelser.
Du kan konvertere tal (f.eks. i A1 står 22), og ved at bruge =A1/24 får du tiden 22:00
og du kan så beregne tider korrekt.
ebea Ekspert
14. september 2018 - 23:12 #4
#3  -  Som et lille tillæg, så husk at formatere cellen som klokkeslæt (12:34)
xl-Enthusiast Ekspert
15. september 2018 - 09:32 #5
I stedet for:

=HVIS(LÆNGDE(D29)>2;(HØJRE(D29;LÆNGDE(D29)-FIND("-";D29)))+":00";" ")

prøv:

=HVIS(LÆNGDE(D29)>2;TIDSVÆRDVÆRDI((HØJRE(D29;LÆNGDE(D29)-FIND("-";D29)))&":00");" ")

Jeg har engelsksproget Excel, så jeg er lidt usikker på, om funktionen TIMEVALUE hedder TIDSVÆRDI på dansk. Check det venligst selv.
ebea Ekspert
15. september 2018 - 09:40 #6
Hvis dette bedre kan hjælpe dig på vej!  Hvis det antages at du stadig har dit tal (14:45-22) i celle D29.

Så din første formel (14:45), som var:
=HVIS(LÆNGDE(D29)>2;(VENSTRE(D29;FIND("-";D29)-1));D29)    sættes i celle O29    og gir dig tallet  14:45

Din anden formel (22), som var:
=HVIS(LÆNGDE(D29)>2;(HØJRE(D29;LÆNGDE(D29)-FIND("-";D29)));" ")    sættes i celle P29, og ændres til:
=HVIS(LÆNGDE(D29)>2;(HØJRE(D29;LÆNGDE(D29)-FIND("-";D29)))/24;" ")
Den gir dig nu tallet 22:00

Begge celler (O29 og P29) formateres som klokkeslæt (12:34).

Du kan nu fratrække dine tidspunkter som du skal.

Eller med den anden formel du havde, herunder:
=HVIS(LÆNGDE(D29)>2;Q29-P29;" ")
Kan du ændre til:    =HVIS(LÆNGDE(D29)>2;REST(Q29-P29;1);"")

Så får du også en udregning af dine timer.
d4s Novice
15. september 2018 - 10:36 #7
Dejligt med alle Jeres input. Jeg glæder mig til at prøve dem i aften, når jeg har ordnet de ting i haven, som min kone mener skal laves :)
Jeg har skam formateret cellerne som klokkeslæt, men det har ikke hjulpet på de timer, der ikke har : efter tallet. Tænker at jeg skal prøve /24. Den havde jeg ikke kendskab til.

Timevalue har jeg forsøgt, men den kan ikke regne med et tidspunkt der hedder 22.

Jeg har testet med værditype, som returnerer at 22 er en tekst, så jeg spekulerede på om det var derfor, excel altid fik resultatet 9:15 uanset hvilken værdi der stod i feltet med 22, når man fratrak 14:45

Som sagt glæder jeg mig til attprøve det hele af og få markeret dette som løsning, så jeg kan komme videre med min næste udfordring. Dem løber vi jo aldrig tør for :)
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Tech Mahindra forlader sit danske hovedkvarter: Tre tilbageværende medarbejdere flytter på kontorhotel
Det indiske selskab Tech Mahindra forlader sit danske hovedkvarter i Ballerup og er i stedet flyttet på kontorhotel med kun tre medarbejdere. Computerworld har besøgt de forladte lokaler. Se billederne her.
Computerworld
"Så kommer Microsoft og siger, at jeg kan få en milliard kroner, men det ændrer jo ikke mit liv så meget"
"Dengang Microsoft bød på os, var det med blandede følelser, for jeg havde allerede 200 millioner kroner stående i banken. Til gengæld skulle jeg aflevere min spændende virksomhed."
CIO
Forleden reparerede en mekaniker min bil: Det kostede 4.200 kroner, som min hjerne snød mig til at betale med et smil
De rationelle it-beslutninger du træffer er måske en illusion. Det lærte jeg da min bil gik i stykker og min hjerne snød mig til at tro, at alt var fint. Til gengæld fandt jeg tre fælder dine it-beslutninger kan falde i.
Job & Karriere
Manden bag Stack Overflow til softwareudviklere og folk i it-branchen: Disse ting skal du lære, hvis du vil undgå at blive tromlet totalt
Interview: Manden bag Stack Overflow og Trello har en opsang til folk i it-branchen. Her er de kompetencer, som du bare skal tilegne dig nu.
White paper
En ny tilgang til Cybersecurity gør din forretning stærkere
Mange virksomheder har en forkert tilgang til Cybersecurity, hvor hvert nyt angreb udløser et køb af den nyeste software, på trods af at der hverken er tid eller ressourcer til at sætte sig ind i de nye systemer. Denne strategi er ikke tidssvarende og holdbar i længden og i dette Whitepaper stiller vi skarpt på hvordan I griber tingene rigtigt an.