Tanja Novice
27. januar 2021 - 15:29 Der er 8 kommentarer og
1 løsning

Hjælp til "DATO.FORSKEL", eller andet der er smartere

Er der mon en kan der hjælpe mig med hvordan jeg får Excel til at returnere 6 måneder i stedet for 5, altså altid tælle sidste måned med, selvom den ikke har 31 dage, eller hvordan den nu regner. Altså "runde op" i stedet for at "runde ned"

31-12-2020    30-06-2021    5    Brugt formel:DATO.FORSKEL(A1;B1;"m")

Datoerne kunne også være
15-01-2020    14-06-2020    4  og her kunne jeg godt tænke mig der blev returneret 5 og ikke 4

Hilsen Tanja
kim1a Ekspert
27. januar 2021 - 16:19 #1
Er der et udfaldsrum hvor du ikke bare skal sige +1?

Selv med 1-1-2020 og 30-6-2020 vælger den vel 4?
ebea Ekspert
27. januar 2021 - 16:21 #2
Du kan bruge en anden formel, som gør det du ønsker:  =HELTAL((B1-A1)/30)
Tanja Novice
27. januar 2021 - 16:28 #3
Jeg har brug for at trække formlen ned i et ark med forskellige til og fra datoer, også med fra og til datoer der går over flere år, så det bliver forkert hvis jeg generelt skriver +1 i formlen.
Har jeg fx i en af rækkerne et tidsrum der går fra 31-12-2020 til 31-12-2020 skal der gerne returneres 24 og ikke 25, som jeg tænker vil ske hvis jeg tilføjer +1 i formlen. Jeg skal bruge de returnerede antal måneder til at beregne huslejeforpligtelser på mange forskelige lejemål, så jeg skal gerne være rimelig sikker på der regnes rigtigt.
Tanja Novice
27. januar 2021 - 16:31 #4
Ebea.. Hvis jeg bruger din formel og forskellen på mine datoer er fx omkring 10år, så synes jeg desværre igen jeg bliver udfordret på at den ikke returnerer korrekte antal måneder.
ebea Ekspert
27. januar 2021 - 16:46 #5
#4 - Vi prøver en, som laver det mere præcist. Så forhåbentlig passer den ind i det du laver.
Har prøvet den på +10 år

=AFRUND((DATO(ÅR(B2);MÅNED(B2);DAG(B2))-DATO(ÅR(A2);MÅNED(A2);DAG(A2)))/(365,25/12);0)
Tanja Novice
27. januar 2021 - 17:24 #6
Tak ebea

#4 ser ud til at fungere.
Fantastisk.. Tak :) 
Jeg mangler så bare lige at få flettet ind i formlen, at hvis værdien bliver negativ (for det gør den nogle steder, på de lejemål hvor uopsigeligheden er udløbet) så skal den returnere tallet 0
Kan du også hjælpe mig her?
ebea Ekspert
27. januar 2021 - 17:49 #7
#6 - Formlen som angivet, skal du være opmærksom på, afrunder ud fra hvor på måneden datoerne er. Hvis delingen af måneden er under halvdelen af måneden, vil den runde til nederste dato.
Hvis den altid skal runde op, skal du bruge  RUND.OP i starten af formlen, i stedet for AFRUND.

Det med at undgå negativ værdi, kan laves med en HVIS funktion. Formlen herunder er godt nok lidt lang, og kan måske laves lidt mere fiks; men den virker.

=HVIS(AFRUND((DATO(ÅR(B1);MÅNED(B1);DAG(B1))-DATO(ÅR(A1);MÅNED(A1);DAG(A1)))/(365,25/12)<0;0);0;AFRUND((DATO(ÅR(B1);MÅNED(B1);DAG(B1))-DATO(ÅR(A1);MÅNED(A1);DAG(A1)))/(365,25/12);0))
Tanja Novice
27. januar 2021 - 17:55 #8
Ebea

Det virker!.. TUSIND TAK :)
ebea Ekspert
27. januar 2021 - 18:13 #9
#8 - Du er velkommen ;-)
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Coloplasts it-direktør: GDPR har givet de it-kriminelle et nyt værktøj til at angribe os
Interview: Det er ikke kun på plads og kapacitet, at sundhedssektoren lige nu er udfordret. De sikkerhedsansvarlige har også fået en del mere at se til gennem et kaotisk 2020. "Cyberkriminelle har opdaget, at der er en hel masse værdi i denne her datatype. Enten som afpresningsmulighed eller som viden, de kan udnytte til noget," siger CIO i Coloplast, René Rasmussen. Læs første artikel i serien om perspektiver fra sektoren, der er de it-kriminelles nye guldkalv
Computerworld
Bill Gates har en løsning: Sådan undgår vi klimakatastrofen
Klumme: Bill Gates vil gerne redde verden. Intet mindre. Og som alle store it-folk regner han baglæns. Politikerne er mest optaget af, hvad der kan lade sig gøre, og hvad de kan skabe flertal for. Men Bill Gates har set på klimakatastrofen, og hans budskab er klart.
CIO
Har du rost din mellemleder i dag? Snart er de uddøde - og det er et tab
Computerworld mener: Mellemledere lever livet farligt: Topledelsen får konstant ideer med skiftende hold i virkeligheden, og moden går mod flade agile organisationer. Men mellemlederen er en overset hverdagens helt med et kæmpe ansvar. Her er min hyldest til den ofte latterliggjorte mellemleder.
Job & Karriere
IBM Danmark trækker tilbud om frivillige fratrædelser tilbage for stort antal ansatte: "IBM har taget røven på sine ansatte"
Som led i IBM Danmarks store fyringsrunde fik 130 ansatte grønt lys til at forlade selskabet på en frivillig fratrædelsesordning. Men nu har IBM Danmark trukket det oprindelige tilbud tilbage for størstedelen af de ansatte.
White paper
Infrastruktur: Byg et velfungerende Data Estate i otte trin
Mange virksomheder trækker på så mange og righoldige datakilder, at det bliver stadig sværere at holde rede på alle de informationer, man har. Samtidig lever et traditionelt data warehouse sjældent op til hverken de aktuelle eller – i særdeleshed – fremtidige krav fra forretningen. Løsningen er at udvide til en egentlig Data Estate; et stykke kritisk infrastruktur som gør det muligt at opbevare, organisere, konsolidere og analysere organisationens samlede datamængde. Denne hvidbog giver et samlet billede af, hvordan man gennem otte trin bevæger sig mod at implementere og drage nytte af en Data Estate. Samt hvordan du prioriterer indsatsen, så den giver størst værdi for forretningen.