Avatar billede Klaus W Professor
19. juli 2021 - 10:17 Der er 17 kommentarer og
1 løsning

Søg i 2 kolonner og returnere værdigen fra tredje kolonne

Hej
Nogle der kan hjælp.
I arket Stamdata kolonne D står hvilket skifte man er på og i kolonne F hvilket kvarter. Nu er det sådan at i celle B 13 jeg skriver hvilket skifte eller kvarter man er på.
Jeg ville bruge den formel til at søge i 2 kolonner i et andet ark men kan ikke få den til at fungere.

=(INDEKS(Stamdata!$A$2:$F$40;SAMMENLIGN($B$13;Stamdata!$D$2:$D$40;0))&SAMMENLIGN($B$13;Stamdata!$F$2:$F$40;0)) som matrix formel.

Nogle der kan hjælpe.
Hilsen og på forhånd tak
Klaus W
Avatar billede Jan K Ekspert
19. juli 2021 - 11:53 #1
Jeg tror at problemt er, at hvis du i B13 kun skriver et skfte eller et kvarter, finder formlen ikke noget.
Avatar billede Klaus W Professor
19. juli 2021 - 13:22 #2
Hej Jan

I celle B13 er en rulle menu, hvor der kan stå følgende

1. SKIFTE
2. SKIFTE
3. SKIFTE
KONGENS KVARTER
DRONINGENS KVARTER

de 3 første står i arket Stamdata kolonne D, de 2 sidste i arket Stamdata kolonne F

KW
Avatar billede store-morten Ekspert
19. juli 2021 - 14:37 #3
Prøv med 2 x LOPSLAG() pakket ind i en =HVIS.FEJL(...)

=HVIS.FEJL(LOPSLAG(B13;TABEL1;FALSK);LOPSLAG(B13;TABEL2;FALSK))
Avatar billede store-morten Ekspert
19. juli 2021 - 14:56 #4
Eks.:
=HVIS.FEJL(LOPSLAG(B13;Stamdata!D2:E40;2;FALSK);LOPSLAG(B13;Stamdata!F2:G40;2;FALSK))

Hvis B13 ikke findes i: Stamdata!D2:D40
Så søg B13 i: Stamdata!F2:F40
Returnerer 1. celle til højre. (kan tilpasses)
Avatar billede Klaus W Professor
19. juli 2021 - 15:10 #5
Hej store-morten
Den skal returner talet fra kolonne A i arket Stamdata.

KW
Avatar billede Klaus W Professor
19. juli 2021 - 15:17 #6
Kommer med et link
Avatar billede store-morten Ekspert
19. juli 2021 - 15:23 #7
Det kan man ikke med LOPSLAG
Avatar billede store-morten Ekspert
19. juli 2021 - 15:43 #8
Prøv:
=HVIS.FEJL(INDEKS(Stamdata!A2:A40;SAMMENLIGN(B13;Stamdata!D2:D40;0);0);INDEKS(Stamdata!A2:A40;SAMMENLIGN(B13;Stamdata!F2:F40;0);0))
Avatar billede store-morten Ekspert
19. juli 2021 - 15:47 #9
Ser lige det er sammen formel som i dit start indlæg :-)
Pakket ind i en HVIS.FEJL(...) i stedet for &
Så det burde virke.
Avatar billede Jan K Ekspert
19. juli 2021 - 16:01 #10
Måske har jeg misfostået noget, men man vel ikke enten på et skifte ellee et kvartet? I min tid i SVN var man på begge dele.
Avatar billede Klaus W Professor
19. juli 2021 - 17:04 #11
Hej store-morten tak for hjælpen, det hjælp men skabte bare et nyt :-( jeg havde ikke tænkt mig om. Den tager godt nok det første tal i kolonne A. Men jeg glemte hvis at sige at der er mange tal der skal føres over UPS. Jeg ved ikke om du lige vil kikke på det.
https://1drv.ms/x/s!AmLaaGiC5LdoiPc_mI31xzCDeYymVA?e=aOLc8n

@Hej Jan K jo det gør man stadig, jeg fik vist ikke forklaret mig helt.
KW
Avatar billede Jan K Ekspert
19. juli 2021 - 17:19 #12
Hvilken version af Excel bruger du? I 365, må det kunne løses med funktionen FILTER()
Avatar billede Klaus W Professor
19. juli 2021 - 18:08 #13
Jeg bruger 2016
Avatar billede Jan K Ekspert
20. juli 2021 - 15:27 #14
OK. Så har du ikke adgsng til FILTER. Men du ksn stadig filtrere listen
Avatar billede Klaus W Professor
20. juli 2021 - 15:51 #15
Hej Jan K jeg kikke på det, tak
Avatar billede store-morten Ekspert
20. juli 2021 - 18:35 #16
Hej Klaus

Har du ikke en brugbar løsning i kolonne H og F ?
Avatar billede Klaus W Professor
21. juli 2021 - 18:22 #17
Hej store-morten
Opgaven er løst med følgende formel.
Tak for jeres bidrag

KW

=HVIS.FEJL(INDEKS(Stamdata!$A$2:$A$43;MINDSTE(HVIS(((Stamdata!$D$2:$D$43=$B$13)+(Stamdata!$F$2:$F$43=$B$13));RÆKKE(Stamdata!$A$2:$A$43)-CELLE("row";Stamdata!$A$2:$A$43)+1);RÆKKER($1:1)));"")
Avatar billede store-morten Ekspert
22. juli 2021 - 00:31 #18
Hej Klaus

Godt du fandt en løsning, hvis du brugte H og F kunne denne bruges:

=HVIS(F17="";H17;F17)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Microsoft drosler ned for lancerings-tempoet for Windows Server: Vil fremover udsende nye releases med flere års mellemrum
Microsoft skrotter sin hidtidige hastige udrulningsplan for Windows Server. Fra og med lanceringen af Windows Server 2022 vil Microsoft udsende nye releases hvert andet eller tredje år.
Computerworld
Tysk unicorn-app stormer ind på det danske marked: Vil levere dine dagligvare-indkøb på 10 minutter
Gorillas er en app-drevet udbringningstjeneste, der er blevet kaldt for Europas hurtigstvoksende startup. Tjenesten vil nu udbringe dagligvare til danskerne inden for 10 minutter.
CIO
Årets CIO 2021: Nu skal Danmarks dygtigste CIO findes - er det dig? Eller kender du en, du vil indstille?
Det er den mest eftertragtede titel for danske it-chefer og CIO'er, der er på spil, når Årets CIO kåres 16. september 2021. Søg selv eller prik til en, som du kender - og læs mere om prisen her.
Job & Karriere
Så meget kan du tjene: Disse stillinger giver den højeste løn i den danske it-branche lige nu
Du skal have ledelsesansvar, hvis du vil helt tops i lønhierakiet i den danske it-branche, viser nye tal. Se hvor meget du kan tjene i de stillinger i it-branchen, der giver den højeste månedsløn lige nu.
White paper
Det bedste fra to verdener: Sådan går du i Azure med VMware
Det er blevet langt lettere at rykke dit VMware-miljø til Microsoft Azure – få den korte og præcise forklaring her.