13. september 2021 - 09:22 Der er 5 kommentarer og
2 løsninger

Referer værdi med udgangspunkt i kryds mellem række og kolonne

I et excel-ark har jeg en kolonne (A)  med navne, og en række (1) med kursusnumre. Jeg ønsker at referere indholdet af den celle, hvis værdi i kolonne A er lig f.eks. 'Mads' og hvis værdi i række 1 er lig "2714".

Hvordan gør jeg det på den smarteste måde?
Avatar billede thomas_bk Ekspert
13. september 2021 - 09:42 #1
En oplagt index/match udfordring

https://trumpexcel.com/index-match/
Avatar billede xl-Enthusiast Ekspert
13. september 2021 - 09:44 #2
Med kursusnumre i B1:H1 og navne i A2:A5, søgt navn i A9 og søgt kursusnummer i A10, prøv:

=INDEKS(B2:H5;SAMMENLIGN(A9;A2:A5;0);SAMMENLIGN(A10;B1:H1;0))
Avatar billede xl-Enthusiast Ekspert
13. september 2021 - 09:52 #3
Hvis du har adgang til XOPSLAG kan du bruge:

=XOPSLAG(A9;A2:A5;XOPSLAG(A10;B1:H1;B2:H5))
13. september 2021 - 15:08 #4
@xl-Enthusiast: Tak - så langt så godt! Så opstår min næste udfordring. Et kursus kan godt have flere kursusnumre (alt afhængig af niveau), og derfor er de enkelte kursusnumre inden for kurset også prioriteret.

Hvordan laver jeg denne reference, hvor der blot er værdien, af det kursnummer med højest prioritet og det pågældende navn?
Avatar billede xl-Enthusiast Ekspert
13. september 2021 - 16:09 #5
Jeg er ikke med på, hvad du mener. Kan du ikke forklare det lidt bedre?
Avatar billede isakajen Praktikant
14. september 2021 - 23:37 #6
Hej
Kan i hjælp mig med Excel formel til dag, morgen, aften og nat timer.
Dag fra kl 06-18
Morgen fra 04-06
Aften fra 18-22
Nat fra 22-04
21. september 2021 - 14:00 #7
@xl-Enthusiast: Jeg prøver at uddybe med udgangspunkt i der i løsningen, jeg er nået til.

Jeg har 5 kolonner (A,B,C,D,E), hvor A:D indeholder kan (dvs. det er ikke fuldkommen data) datoer. I den femte kolonne (E), vil jeg gerne have refereret datoen fra den kolonne længst til højre (rækkefølgen er derfor D-C-B-A), som har en værdi.

Dvs. er der en dato i D skal den refereres. Men er der ikke en dato i D men i C, skal datoen fra C refereres osv.

Giver det mening nu?
På forhånd tak.
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Ny rekord: Her er elbilen med den længste rækkevidde / Få timer til at Apple er klar med ny iOS 15 / Teslas vilde model S Plaid sætter fantomtid på hæderkronet bane