Avatar billede PMarco Novice
14. september 2021 - 09:02 Der er 9 kommentarer og
2 løsninger

Flere afrund regler

Hej eksperter,

Jeg håber i kan hjælpe mig med nedenstående.

Jeg har brug for hjælp til følgende.
Hvis tallet i cellen er mellem 10 og 100 skal der rundet op til nærmeste 95 øre, er tallet større end 100 skal det rundes op til nærmeste heltal.

Eksempel: står der i cellen 11,34 = 11,95
Eksempel: står der i cellen 103,59 = 104,-
Eksempel: står der i cellen 7,34 = 7,34

Med venlig hilsen
Patrick
Avatar billede thomas_bk Ekspert
14. september 2021 - 09:15 #1
I mangel af bedre, så vil jeg foreslå at gøre brug af Ifs() den hedder nok Hviser på dansk.
Den funktion udfører den første betingelse der er opfyldt.
Avatar billede kim1a Ekspert
14. september 2021 - 09:20 #2
Er det ikke bare
=if(tal<100;if(tal>10;rund 95 øre;tal);rund heltal)
Avatar billede xl-Enthusiast Ekspert
14. september 2021 - 09:29 #3
IF((A1>=10)*A1<=100);ROUNDUP(A1;0)-0,05;IF(A1>100;MROUND(A1;1);
ROUND(A1;2)))

dansk:

=HVIS((A1>=10)*A1<=100);RUNDOP(A1;0)-0,05;HVIS(A1>100;MAFRUND(A2;1);
AFRUND(A1;2)))
Avatar billede xl-Enthusiast Ekspert
14. september 2021 - 09:30 #4
Der skulle have været et lighedstegn foran IF i den førsate formel.
Avatar billede PMarco Novice
14. september 2021 - 10:04 #5
Hej xl-Enthusiast,

Tak for dit svar, men formlen fejler desværre.

Har du/I et andet bud?
Avatar billede xl-Enthusiast Ekspert
14. september 2021 - 11:13 #6
Jeg var kommet til at skrive A2 i stedet for A1 i MAFRUND-delen.

Er det her bedre

=HVIS((A1>=10)*A1<=100);RUNDOP(A1;0)-0,05;HVIS(A1>100;MAFRUND(A1;1);
AFRUND(A1;2)))
Avatar billede xl-Enthusiast Ekspert
14. september 2021 - 11:19 #7
En ting mere - jeg tror det hedder RUND.OP i stedet for RUNDOP (beklager, jeg bruger engelsksproget Excel)
Avatar billede jens48 Ekspert
14. september 2021 - 12:03 #8
=A1*(A1<10)+(INT(A1)+0,95)*(A1>=10)*(A1<100)+ROUNDUP(A1;0)*(A1>=100)

På dansk er INT=HELTAL og ROUNDUP=RUND.OP
Avatar billede PMarco Novice
14. september 2021 - 13:10 #9
Det hjalp desværre ikke. Det er som om, at excel brokker jeg ved =100.

Du kan godt skrive den på engelsk hvis den virker for dig.
Avatar billede anedi Ekspert
14. september 2021 - 13:36 #10
Måske denne:
=HVIS(A1<10;A1;HVIS(A1<100;RUND.OP(A1;0)-0,05;RUND.OP(A1;0)))
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Ny rekord: Her er elbilen med den længste rækkevidde / Få timer til at Apple er klar med ny iOS 15 / Teslas vilde model S Plaid sætter fantomtid på hæderkronet bane