Avatar billede Nervatos Seniormester
01. december 2021 - 15:06 Der er 5 kommentarer og
1 løsning

Runde op til nærmeste i en række

Halløj derude

Hvis jeg har en række med følgende:

C1 10
C2 13
C3 16
C4 20
C5 25

Hvis jeg så får et resultat 12, så skal den runde op til 13. Ligeledes, hvis resultatet er 16 skal den runde op til 20 osv?

Har forsøgt at rode lidt med afrund.loft - men har lidt svært ved at gennemskue den rigtige formel.

God dag.
Avatar billede Jan K Ekspert
01. december 2021 - 15:53 #1
Forstår ikke helt logikken. 12 skal rundes op til 13, men 16, som står i kolonnen, skal runxes op til 20?
Avatar billede Nervatos Seniormester
01. december 2021 - 19:27 #2
#1, Kan jeg godt forstå, men vi kan også til at starte med bare tage det inden for rækken.
Avatar billede jens48 Ekspert
01. december 2021 - 22:37 #3
Din kommentar i #2 får det stadig ikke til at virke logisk, men hvis jeg blot går ud fra overskriften kan det lade sig gøre med Match og index med denne formel når tallet der skal rundes op står i E1:

=INDEX(C1:C5;MATCH(E1;C1:C5;-1))

Det kræver dog at tallene i C1:C5 bliver sorteret i omvendt rækkefølge

På dansk bliver formelen til:

=INDEKS(C1:C5;SAMMENLIGN(E1;C1:C5;-1))
Avatar billede Nervatos Seniormester
01. december 2021 - 22:44 #4
#2, Tak for dit bud. Jeg får blot #I/T som resultat.
Avatar billede jens48 Ekspert
01. december 2021 - 22:48 #5
Har du husket at sortere C1:C5 så største værdi stå øverst?
Avatar billede Nervatos Seniormester
01. december 2021 - 23:01 #6
#5, Havde misset en celle, tak for hjælpen!
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Sådan tager top-CIO Pernille Geneser livtag med 40 år gamle it-systemer i Stark Group med 10.000 medarbejdere