Avatar billede HHA Forsker
28. januar 2022 - 08:19 Der er 9 kommentarer og
1 løsning

Sum ender med #VÆRDI

Hejsa,

Kæmper med at en formel returnerer med #VÆRDI, når P9 er 0 eller tom.
I cellen P9, har jeg en formel der skal beregne, hvis der er noget at beregne.
Men tiltider skal den ikke beregne og så har jeg den trælse #VÆRDI stående.
 
Har denne formel i cellen, som viser værdi, når P9 viser ingen ting: =HVIS(P9=0;"";(SUM(R32-P9)))

Har prøvet flere ting, men uden held....
Avatar billede kim1a Ekspert
28. januar 2022 - 08:35 #1
=hvis.fejl(din formel;"") på engelsk =iferror(dinformel;"")

Så vil din celle være tom når den driller.
Avatar billede HHA Forsker
28. januar 2022 - 09:12 #2
Takker kim1a 👍
God weekend!
Avatar billede madklub Professor
28. januar 2022 - 09:24 #3
Hvad vil du regne ud med denne del: SUM(R32-P9)?

Du trækker P9 fra R32 i en sumformel.
Bare skriv R32-P9.
Avatar billede HHA Forsker
28. januar 2022 - 13:57 #4
ikke andet end du skriver =SUM(R32-P9)
Men hvis P9 er tom returnerer den #VÆRDI ved mig.
Det syntes jeg var træls, når der ikke altid er nogen værdi i P9.

Den kunne jeg sgu ikke greje, selv om jeg havde prøvet forskellige formler.
Men kim1a skrev det der skulle til.
Avatar billede madklub Professor
28. januar 2022 - 15:42 #5
Men en sum er jo tal der er lagt sammen - adderet.
Hvis du vil trække et tal fra et andet, skal du ikke bruge SUM.
Avatar billede xl-Enthusiast Ekspert
29. januar 2022 - 11:49 #6
Men det der lægges sammen kan sagtens være en blanding af positive og negative tal, så du kan ikke generelt sige, at man ikke skal bruge funktionen SUM.
Avatar billede madklub Professor
29. januar 2022 - 12:14 #7
At bruge SUM(X-Y) giver ingen mening.
Brug X+Y eller X-Y.
Avatar billede xl-Enthusiast Ekspert
29. januar 2022 - 12:35 #8
Så hvis jeg i A1:A5 har
335
-463
379
-382
206

Så vil du bruge A1-A2+A3-A4+A5 for at få resultatet 75?

Jeg vil bruge: =SUM(A1:A5)

Læg mærke til, at jeg sagde;
du kan ikke generelt sige, at man ikke skal bruge funktionen SUM.
Avatar billede madklub Professor
29. januar 2022 - 13:40 #9
Det vil jeg selvfølgelig også gøre.
SUM bruges når man har flere tal der skal lægges sammen.

Men hvis jeg har ét tal der skal trækkes fra ét andet. Så er underligt at bruge SUM, fordi den funktion - som udgangspunkt - bruges til at lægge flere tal sammen.
Avatar billede store-morten Ekspert
29. januar 2022 - 18:18 #10
Der er nu en fordel ved at bruge en =SUM( ) formel, dog på lidt andet vis.
Den tager jo summen i cellerne, og ser bort fra "tomme" og celler med andet indhold.

=SUM(R32)-SUM(P9)
Vil beregne hvis P9 er "Tom"
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Årets CIO 2022: Nu skal Danmarks dygtigste CIO findes - er det dig? Eller kender du en, du vil indstille?