HHA Seniormester
27. januar 2021 - 14:12 Der er 10 kommentarer og
1 løsning

Automatisk udfyldning af datoer

Hejsa,

Hvis jeg i række B10 til B20 har ugenumre manuelt indskrevet, hvordan får jeg så Excel til automatisk at udfylde cellen lige under med datoer for ugens længde (mandag til søndag, fx. 1-7 / 2 (1. feb. til 7 feb.))
Og den skulle gerne tage højde for skudår og 53 uger :)
claes57 Ekspert
27. januar 2021 - 15:09 #1
hvor har du årstal? (aktuelt år kan ikke bruges omkring nytår)
HHA Seniormester
27. januar 2021 - 15:33 #2
Hejsa,

Det kan vi bare sætte til A1

Hvad mener du med: aktuelt år kan ikke bruges omkring nytår ?
Er det det med 53 uger?
claes57 Ekspert
27. januar 2021 - 15:57 #3
hvis du laver ugenumre d. 30 dec så kan den udfylde den uge - men hvis du laver samme øvelse d. 2 jan så er aktuelt år +1, og passer ikke længere. Det er start på året, er det 53 eller 1 og ligger det i det angivne år i A1
Det primære er ud fra år/ugenummer at finde datoen for mandag - og i de følgende 6 felter bare lægge en til datoen.

og så dur "række B10 til B20 har ugenumre" så bliver datoer nødt til at stå vandret ud til højre, og ikke nedenunder.

vil ugenumre være fortløbende? så kan de efterfølgende jo bare beregnes som den den ovenover + 1 i dato. Eneste opgave er første mandag i første uge.
HHA Seniormester
27. januar 2021 - 16:10 #4
Det er noget sludder jeg skrev.
Det er B10 til K10 og gerne i feltet lige neden under :)

Men tror godt jeg kan leve uden det lige omkring nytår.

Nej uge numre vil ikke være fortløbende, så formel skal kunne beregne det fra uge nummeret oven over.
jens48 Ekspert
27. januar 2021 - 16:25 #5
Prøv med

=IF(WEEKDAY(DATE($A$1;1;1);2)<5;DATE($A$1;1;1)+1-WEEKDAY(DATE($A$1;1;1);2);DATE($A$1;1;1)+8-WEEKDAY(DATE($A$1;1;1);2))+7*(B10-1)

På dansk:

=HVIS(UGEDAG(DATO($A$1;1;1);2)<5;DATO($A$1;1;1)+1-UGEDAG(DATO($A$1;1;1);2);DATO($A$1;1;1)+8-UGEDAG(DATO($A$1;1;1);2))+7*(B10-1)
claes57 Ekspert
27. januar 2021 - 16:32 #6
#5 den skal så i b11 og kopieres til k11
i b12 og frem til k17 skal bare være =dato fra felt ovenover + 1 dag
store-morten Ekspert
27. januar 2021 - 16:59 #7
Med Årstal i: A1
Og uge nr i: B10 til K10

Prøv med formlen i: B11

=TEKST(DATO($A$1;1;-3)-UGEDAG(DATO($A$1;1;3);1)+(B10*7)+1;"DD-MM") & " / " & TEKST(DATO($A$1;1;-3)-UGEDAG(DATO($A$1;1;3);1)+(B10*7)+7;"DD-MM")

og fyld ud til K10
HHA Seniormester
27. januar 2021 - 17:46 #8
Det bliver store-morten der løber med "sejren" :)

Den han kommer med, viser dato som jeg efterspurgte.
Måske jeg ikke havde forklaret mig godt nok, men store-morten fangede den 👍

Tak igen til jer alle for den hjælpsomhed der er her inde...
HHA Seniormester
27. januar 2021 - 17:48 #9
Tror ikke det er muligt, men kan den fx vise 1-7/02 i stedet for 25-01 / 31-01 ?
HHA Seniormester
27. januar 2021 - 17:51 #10
Glem ovenstående, den kan da ikke skrive det hen over 2 mdr. 🤣
store-morten Ekspert
27. januar 2021 - 19:02 #11
Velbekomme 🤝
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Danmarks bedste CIO havde ét krav til ny topstilling: Derfor afviste han flere internationale topjobs - og sagde ja til Fiskars
Interview: Der har ikke manglet jobtilbud for vinderen af Årets CIO 2020, Peter Cabello Holmberg, der tidligere på året forlod Pandora efter hans stilling blev nedlagt. Han var dog ikke i tvivl om, at den finske produktionsgigant var den rigtige virksomhed for ham.
Computerworld
Intel taber retssag og skal betale to milliarder dollar: "Det er skandaløst"
Chipgiganten Intel har tabt en retsag i USA, og er blevet idømt en bøde på hele 2,1 milliarder dollar. Det er en af de største bøder for en patentsag i USA's historie.
CIO
Har du rost din mellemleder i dag? Snart er de uddøde - og det er et tab
Computerworld mener: Mellemledere lever livet farligt: Topledelsen får konstant ideer med skiftende hold i virkeligheden, og moden går mod flade agile organisationer. Men mellemlederen er en overset hverdagens helt med et kæmpe ansvar. Her er min hyldest til den ofte latterliggjorte mellemleder.
Job & Karriere
IBM Danmark trækker tilbud om frivillige fratrædelser tilbage for stort antal ansatte: "IBM har taget røven på sine ansatte"
Som led i IBM Danmarks store fyringsrunde fik 130 ansatte grønt lys til at forlade selskabet på en frivillig fratrædelsesordning. Men nu har IBM Danmark trukket det oprindelige tilbud tilbage for størstedelen af de ansatte.
White paper
IDC – styrken af en hybrid cloud strategi
Cloud computing er blevet en integreret del af forretningsstrategi og it-arkitektur for mange virksomheder i løbet af det sidste årti. Brugen af cloud er blevet udbredt, fordi virksomheder vil indføre nye forretningsmodeller, udtrække værdifuld indsigt fra enorme datamængder, håndtere krævende arbejdsbelastninger, levere nye produkter hurtigere og opnå konkurrencemæssige fordele. Men cloudadoption har også introduceret nye udfordringer. Denne undersøgelse af virksomhedens it-kunder fremhæver de største udfordringer med offentlig cloud.