Avatar billede SME Praktikant
24. maj 2022 - 11:00 Der er 1 kommentar og
1 løsning

Kombination af lopslag og hvis - funktion

Jeg har to regneark.
I ark 1 har jeg en kolonne, A, med unikt ID.
I ark 2 har jeg et udtræk fra SAP, hvor der i kolonne A er samme unikke ID-numre som i ark 1
I ark 2 har jeg i kolonne C nogen gange en værdi, nogen gange ikke. Når der er en værdi er denne en dato, altid 31.12.1999. (datoen er underordnet, det er det, at der er en værdi i feltet, der er interessant)

Jeg har forsøgt at lave en formel der i indsætter et "1"-tal i kolonne J i regneark 1 såfremt der for det unikke ID er en datoværdi i kolonne C i regneark 2. Hvis der for det unikke ID ikke er en værdi i regneark 2 skal feltet i regneark 1 bare være blankt.

Min formel ser således ud:
=HVIS(ER.IKKE.TILGÆNGELIG(LOPSLAG(A2;'regneark2'!$A$24:$A$1100;3;FALSK));"";1)

Jeg får nogle 1-taller i kolonne J, men stemmer ikke overens med hvor der er datoangivelser i regneark 2.

Er der nogen af jer, der kan gennemskue hvori fejlen i min formel består?

Vh SME
Avatar billede ebea Ekspert
24. maj 2022 - 11:57 #1
Kan også laves med en INDEKS formel.
=HVIS(INDEKS('Ark2'!$C$24:$C$1100;SAMMENLIGN(A2;'Ark2'!$A$24:$A$1100;0));1;"")
Avatar billede kim1a Ekspert
24. maj 2022 - 12:11 #2
Jeg ville nok have forsøgt noget med længden af det opslaget giver. De fleste opslag ender jo som tekst, ellers ville det være elegang at checke om det er en valid dato.
If(len(xlookup)=datolængde;1;0)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
2BM fokuserer benhårdt på vækst og kultur ved salget til SOA: "Vi har ikke cashet ind og gået ind i et af de store firmaer. Vi har sat foden ned og sagt nej, vi bliver her og skal bygge en kæmpestor SAP-forretning op."
CIO
Stort CIO-interview: Lemvigh-Müllers milliard-omsætning er blevet digital