jisch Juniormester
13. marts 2018 - 23:18 Der er 1 kommentar og
1 løsning

Absolut og relativ celler

Dette er svært at beskrive, men jeg prøver:

Jeg har en række A1:E1 med værdier. Jeg har en kolonne H1:H5 med værdier.

Jeg vil gerne oprette en ny række A3:E3 med funktion mellem A1 - H1, B1 -H2....etc.

Det kan jeg naturligvis gøre manuelt ved at skrive (A3)=A1*H1, (B3)=B1*H2...etc.

Nu til spørgsmålet: Hvordan skriver jeg en funktion i  A3 (=A1*H1) som jeg kan kopiere fra A3 til E3 (altså rækken A1:E1 relativ til H1:H5)?
xl-Enthusiast Ekspert
14. marts 2018 - 05:29 #1
I A3:

=INDEX($A$1:$E$1;COLUMNS($A:A))*INDEX($H$1:$H$5;COLUMNS($A:A))
på dansk:
=INDEKS($A$1:$E$1;KOLONNER($A:A))*INDEKS($H$1:$H$5;KOLONNER($A:A))
kopier til E3.

Eller:
=INDIREKTE("r[-2]c";0)*INDIREKTE("r["&-2+KOLONNER($A:A)-1&"]c8";0)
men den første (INDEKS) er den bedste.
xl-Enthusiast Ekspert
14. marts 2018 - 08:13 #2
Endnu en mulighed er at bruge en multicelle matrixformel. Vælg A2:E2 og indtast

=A1:E1*TRANSPONER(H1:H5)

Afslut ved at holde Ctrl og Shift nede før tryk på Enter.
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester



Seneste spørgsmål Seneste aktivitet
I dag 14:19 Afslut funktion i case Af BDV i C#
I dag 13:32 Certifikatfejl Af Bordeaux i Browsere
I dag 12:45 Hvor vigtigt er secure boot? Af fileto i Windows
I dag 12:28 array i en en case Af BDV i C#
I dag 10:20 Lås to kolonner sammen Af Torben Hehr i Excel


Premium
Facebook er virksomheden der kan eje verden, hvis den kommer helskindet igennem sin identitetskrise
Selvom Facebooks aktie er blevet sendt til tælling over sommeren, har den gode odds i fremtiden. Selvskabet har nemlig en unik evne til at navigere igennem kriser.
CIO
Forleden reparerede en mekaniker min bil: Det kostede 4.200 kroner, som min hjerne snød mig til at betale med et smil
De rationelle it-beslutninger du træffer er måske en illusion. Det lærte jeg da min bil gik i stykker og min hjerne snød mig til at tro, at alt var fint. Til gengæld fandt jeg tre fælder dine it-beslutninger kan falde i.
Job & Karriere
Her er syv job-annoncer der overrasker med helt usædvanlige overskrifter
Der er mange ledige it-job i øjeblikket. It-jobbank har her fundet syv spændende stillinger, der har det til fælles, at annoncen har en utraditionel overskrift.
White paper
Fire trin til øget cybersikkerhed på den digitale arbejdsplads
Organisationer af enhver størrelse er i konstant risiko for at blive udsat for cyberangreb, som potentielt kan ende med at koste millioner af kroner. I de kommende år vil reguleringer, som den nye EU-persondataforordning, kunne straffe virksomheder med gigantiske bøder, for utilstrækkelig sikring af deres systemer og data. Hvordan dette kan undgås, kan du læse mere om i dette whitepaper.