Avatar billede prinsib Seniormester
29. oktober 2019 - 13:19 Der er 25 kommentarer

Viser #værdi

Hej her inde.
Hvorfor viser den #værdi, og kan i hjælpe mig.
=hvis(C5<>””;(c9+c18+c24+c31+c36);””)
Denne formel gir #værdi hvis der kun står noget i c9 c18 c24 o.s.v.
Ib
Avatar billede Thomas S Ekspert
29. oktober 2019 - 13:29 #1
du skal kigge på celleformatering - hvis det er tekst kan du ikke tælle det sammen med tal - derudover hvis du har et punktum i en af cellerne (2.3 feks.) så er det også tekst og kan ikke benyttes som tal
Avatar billede ebea Ekspert
29. oktober 2019 - 13:37 #2
Du har formentlig dansk Excel, men citationstegn fra en engelsk version. Prøv dette:
=HVIS(C5<>"";(C9+C18+C24+C31+C36);"")
Avatar billede prinsib Seniormester
29. oktober 2019 - 14:47 #3
Hej Thomas.
Cellerne er formateret som tal, og der står en formel i dem.
Ebea. Er det ikke det samme som min formel.
Ib
Avatar billede ebea Ekspert
29. oktober 2019 - 14:56 #4
#3  -  NEJ; læs hvad jeg skriver! Indsæt den formel jeg har uploadet, og prøv!
Avatar billede prinsib Seniormester
29. oktober 2019 - 15:31 #5
sorry ebea. har prøvet at kopiere din formel uden held.
Ib
Avatar billede ebea Ekspert
29. oktober 2019 - 15:33 #6
#5  -  Hvis jeg retter din formel, så den er som den jeg uploadede, så virker eks. her hos mig. Din #NAVN fejl, kommer grundet dine citationstegn, som stammer fra en engelsk version af Excel.
Avatar billede ebea Ekspert
29. oktober 2019 - 15:37 #7
Her er et eks. med dine tal, og den foreslåede formel:
https://www.dropbox.com/s/za3djcjepxluq37/sum.xlsx?dl=0
Avatar billede store-morten Ekspert
29. oktober 2019 - 17:19 #8
#ebea
Formlen giver: #VÆRDI ikke: #NAVN

#prinsib
En af dine sum celler indeholder en forkert data type, f.eks. tekst?
Prøv med: =HVIS(C5<>"";SUM(C9;C18;C24;C31;C36);"")
Som ignorerer celler med tekst.
Avatar billede ebea Ekspert
29. oktober 2019 - 17:34 #9
#8  -  Hvis man opstiller det som han oplyser (og vist i mit eks.), så får han en #fejl (Navn, og ikke værdi); jeg kan ikke se hvor værdi fejlen skal opstå!
Og uanset om han fjerner et, eller flere tal fra den opstilling, så virker formlen, hvis han retter sine citationstegn!
Avatar billede store-morten Ekspert
29. oktober 2019 - 17:37 #10
Jeg er ret sikker på at citationstegn fejlen er en copy/paste fejl
Avatar billede store-morten Ekspert
29. oktober 2019 - 17:39 #11
Prøv at skrive en tekst i en sum celle for at test din formel ;-)
Avatar billede ebea Ekspert
29. oktober 2019 - 17:54 #12
#11 - ja, men jeg skal jo ikke summere en tekst! Kun tal. Så jeg forstår ikke hvor du vil hen med det. Og selvom jeg skriver en tekst, virker formlen stadig ;-)
Avatar billede store-morten Ekspert
29. oktober 2019 - 18:00 #13
Jeg vil der hen at en af de 5 celler (med formler) indeholder en forkert data type.

Hvis du i dit ark skiver: test i celle C9 giver din formel: #VÆRDI
Avatar billede store-morten Ekspert
29. oktober 2019 - 18:09 #14
Og lur mig hvis ikke en af cellerne: C9,18, 24, 31 eller 36
indeholder en HVIS formel ala: =HVIS(celle="";"";noget andet)
og denne returnere: "tom" som er en forkert data type.
Avatar billede ebea Ekspert
29. oktober 2019 - 18:11 #15
#13  -  ja den vej rundt, er det korrekt. Men jeg går ud fra det som spørgeren skriver ....."Denne formel gir #værdi hvis der kun står noget i c9 c18 c24 o.s.v." at han summerer tal, og ikke tekst! Forstået, at hvis ikke der stod noget i én af cellerne, fik han en # fejl.
Avatar billede store-morten Ekspert
29. oktober 2019 - 18:17 #16
Ja, men hvem tænker på at man ikke kan regne på: "" (tom) celle ;-)
Avatar billede store-morten Ekspert
29. oktober 2019 - 18:22 #17
Så: =SUM(C9;C18;C24;C31;C36) i stedet for: =(c9+c18+c24+c31+c36) gør Tricket.
Avatar billede ebea Ekspert
29. oktober 2019 - 18:26 #18
#17 - Eller forkort formlen, når den ser sådan ud, som du har angivet: =HVIS(C5<>"";SUM(C9:C36);"")
Avatar billede store-morten Ekspert
29. oktober 2019 - 18:28 #19
Borset fra at den summerer alle celler fra C9 til C36 og ikke de 5
Avatar billede ebea Ekspert
29. oktober 2019 - 18:43 #20
#19 - Ja! slut herfra ;-)
Avatar billede prinsib Seniormester
29. oktober 2019 - 19:30 #21
Tak for din hjælp ebea. Jeg skrev i #4 at der står formler i cellerne, så det må være derfor.
Morten din formel i #14 virker som den skal, så tak også til dig.
Ib
Avatar billede store-morten Ekspert
29. oktober 2019 - 19:32 #22
Har jeg ret i min formodning om HVIS formler?
Avatar billede jens48 Ekspert
29. oktober 2019 - 21:42 #23
Hvis du ikke vil have fejl, hvis der er tekst i en af cellerne og du kun vil tælle de angivne celler kan denne formel bruges:

=HVIS(C5<>"";SUM(C9)+SUM(C18)+SUM(C24)+SUM(C31)+SUM(C36);"")
Avatar billede store-morten Ekspert
29. oktober 2019 - 21:59 #24
#jens48 er formlen fra #8 ikke mere enkel?
=HVIS(C5<>"";SUM(C9;C18;C24;C31;C36);"")
Avatar billede prinsib Seniormester
29. oktober 2019 - 23:30 #25
store-morten.
Du havde helt ret, der var en del hvis formler i cellerne.
Igen tak for din løsning.
Ib
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Sådan tager top-CIO Pernille Geneser livtag med 40 år gamle it-systemer i Stark Group med 10.000 medarbejdere