michaelrar Seniormester
18. oktober 2020 - 18:44 Der er 4 kommentarer og
1 løsning

Formel: Søg efter værdi og retur værdi fra cellen i næste kolonne

Hej

Jeg har et ønske om, at søge efter en værdi fra en celle (f.eks. "A1") i området
"B1:G20", hvorefter at få returneret værdien i cellen th. for min fundne værdi.

Havde det været `VBA, så havde jeg snildt lavet det, men med formler er jeg løbet tør for gode ideer. Nogen der kan hjælpe ?

Eksempel
Celle "A1" = Æble

I celle "F17" har jeg værdien Æble. I celle G17 har jeg så værdien jeg ønsker returneret.
Takker mange gange på forhånd
jens48 Ekspert
18. oktober 2020 - 20:11 #1
Brug et par hjælpeformler. I B21 skrives

=IFERROR(MATCH($A$1;B1:B20;0);0)

som kopieres til cellerne B21:G21

I celle H1 skrives

=IFERROR(MATCH($A$1;B1:G1;0);0)

som kopieres til cellerne H1:H20

Så kan den ønskede værdi findes med:

=INDEX(B1:G19;SUM(B21:G21);SUM(H1:H20)+1)

Dansk oversættelse:
=HVIS.FEJL(SAMMENLIGN($A$1;B1:B20;0);0)
=HVIS.FEJL(SAMMENLIGN($A$1;B1:G1;0);0)
=INDEKS(B1:G19;SUM(B21:G21);SUM(H1:H20)+1)
jens48 Ekspert
18. oktober 2020 - 20:14 #2
Ups, der skulle have stået
=INDEX(B1:G20;SUM(B21:G21);SUM(H1:H20)+1)
=INDEKS(B1:G20;SUM(B21:G21);SUM(H1:H20)+1)
igoogle Forsker
19. oktober 2020 - 08:10 #3
Alternativt kan du bruger xopslag

=XOPSLAG(A1;B1:M1;C1:N1;;0)
xl-Enthusiast Ekspert
19. oktober 2020 - 08:27 #4
Med A1:G20 navngivet rng. og med opslagsværdien ("æble") i I1 prøv følgende:

=OFFSET(A1;SUMPRODUCT((rng.=I1)*(ROW(rng.)-CELL("row";rng.)+1))-1;SUMPRODUCT((rng.=I1)*(COLUMN(rng.)-CELL("col";rng.)+1)))

dansk:

=FORSKYDNING(A1;SUMPRODUKT((rng.=I1)*(RÆKKE(rng.)-CELLE("row";rng.)+1))-1;SUMPRODUKT((rng.=I1)*(KOLONNE(rng.)-CELLE("col";rng.)+1)))

https://www.dropbox.com/scl/fi/1i3nhw29p7vte6asie0pt/Find_Tekst.xlsx?dl=0&rlkey=xev9kufto80ep54y4ft7bpzs6
michaelrar Seniormester
19. oktober 2020 - 17:43 #5
Tak for inputtene

Det blev xl-Enthusiast som tog stikket, da den løsning nok passer bedst til mit behov.


Gó aften
Michael
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Computerworld
Det nye MitID er et tigerspring for bedre cybersikkerhed
Klumme: Det nye MitID er en enestående mulighed for et markant løft af it-sikkerheden i danske kommuner. Med baggrund i udfasningen af det nuværende NemID kan de samtidig forbedre og styrke deres it-systemers værn overfor cyberangreb.
CIO
Podcast: Hos Viking Life-Saving Equipment er it gået fra at være backend til at være noget, som kunderne spørger aktivt efter
Podcast, The Digital Edge: Viking leverer en stadig større del af deres produkt som en tjeneste. Som en del af tjenesten tager Viking ansvar for sikkerheden ved at levere, dokumentere og vedligeholde det nødvendige sikkerhedsudstyr. Hør hvordan Henrik Balslev senior digital director hos Viking har løftet den opgave.
Job & Karriere
Regner din ferie væk? Brug tiden på at søge en af disse otte stillinger, der er ledige netop nu
Det sjasker ned over hele Danmark. Du kan bruge de våde sommerdage på at søge et af disse otte job, der er ledige lige nu.
White paper
Styrk brugeroplevelse, produktivitet og medarbejdertilfredshed
Brugervenlige og velfungerende IT-løsninger og -enheder er en af de vigtigste forudsætninger for medarbejdernes produktivitet – men også for at øge deres tilfredshed med arbejdspladsen. Det gælder uanset, om de arbejder fra kontoret eller fra hjemmet. Omvendt ses rigide, topstyrede processer og besværlige systemer som en af de største hindringer for at kunne yde sit optimale. Der er med kort sagt vægtige argumenter for at tage temperaturen på virksomhedens tilgang til brugervenlighed og undersøge, hvordan man kan gøre medarbejdernes hverdag lidt lettere. Det får du mere viden om i denne hvidbog, der også rummer en række konkrete og virkelighedsnære problemscenarier – samt konkrete bud på, hvordan man i hvert enkelt tilfælde kan afhjælpe dem.