Erik R Juniormester
21. november 2020 - 07:06 Der er 6 kommentarer og
1 løsning

Find næste fødselsdag/årlige mærkdag

I kolonne A er anført en række begivenheder, i kolonne B datoen for første forekomst. I Kolonne C vil jeg gerne have datoen for næste årlige forekomst.
Fx
A3:  Peter født
B3: 10/3/2007
C3: 10/3/2021
Hvilken formel kan bruges i C3
Venlig hilsen
Erik R
ebea Ekspert
21. november 2020 - 08:39 #1
=DATO(ÅR(B3)+1;MÅNED(B3);DAG(B3))
kim1a Ekspert
21. november 2020 - 11:12 #2
Du må skulle have en now formel med ind i det. Det #1 kommer med bliver vel blot 10/3-2002
Hvad med:
=hvis(idag()>dato(år(idag());måned(B3);dag(B3);dato(år(idag()+1);måned(B3);dag(B3);dato(år(idag());måned(B3);dag(B3))
Jan K Ekspert
21. november 2020 - 11:52 #3
#2 Det er da ligegyldigt, hvad dag der er i dag, hvis OP kun vil vide, hvilken dato begivenheden indtræffer et rå fra den dato, som allerede er indtastet i B3. Et år af 1-12-20 er jo 1-12-21 uanset, hvad dato, det i dag kun er 21-11-20.
Erik R Juniormester
21. november 2020 - 13:54 #4
Tak for alle bidrag
Mit forsøg gik ud på at finde den først kommende årsdag (anniversary) efter i dag- uanset årstal for den oprindelige mærkedag.
Efter justering af altal paranteser er forslaget fra  Kim1a følgende:
=HVIS(IDAG()>DATO(ÅR(IDAG());MÅNED(B3);DAG(B3));DATO(ÅR(IDAG()+1);MÅNED(B3);DAG(B3));DATO(ÅR(IDAG());MÅNED(B3);DAG(B3)))

Det viser sig at 1-tallet i udtrykket "DATO(ÅR(IDAG()+1)" kun tæller en dag frem - ikke et år.
Hvis forslaget ændres til:
=HVIS(IDAG()>DATO(ÅR(IDAG());MÅNED(B3);DAG(B3));DATO(ÅR(IDAG()+365);MÅNED(B3);DAG(B3));DATO(ÅR(IDAG());MÅNED(B3);DAG(B3)))
virker det efter hensigten - så vidt jeg umiddelbart kan gennemskue vil det dog ikke vise rigtigt den 1. januar i et skudår.
Venlig hilsen
Erik
ebea Ekspert
21. november 2020 - 14:34 #5
#4 - ja, jeg var ikke lige med, i dit oprindelige spørgsmål ;-) Men det kan også laves med følgende formel, hvor C3 er datoen i dag:
=EDATO(B3;(DATO.FORSKEL(B3;C3;"y")+1)*12)
Erik R Juniormester
21. november 2020 - 16:26 #6
Så vidt jeg kan se, er ovenstående formel fra ebea en elegant løsning
[kan også skrives: =EDATO(B3;(DATO.FORSKEL(B3;IDAG();"y")+1)*12)]
tak for alle bidrag
Erik
ebea Ekspert
21. november 2020 - 16:47 #7
#6 - Som altid i Excel, er der flere muligheder. Dette var en kortere version, end de andre, nu når jeg så hvad du faktisk ville ;-)
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Grundfos fyrer to-cifret antal it-medarbejdere i stor omstrukturering
Den store fyringsrunde i Grundfos i september har fået konsekvenser for selskabets it-afdeling, der bliver beskåret. Et to-cifret antal it-medarbejdere er blevet opsagt.
Computerworld
Stein Bagger gør comeback i ny branche: "De lignede et mafiahold, førte sig frem som nyrige og plaprede løs om urealistiske drømme"
Stein Bagger har skiftet navn og fører sig nu frem i store biler i en helt ny branche, skriver en dansk avis.
CIO
Podcast: Her er seks gode råd om ledelse og digitalisering fra danske top-CIO'er
The Digital Edge: Vi har talt med 17 af Danmarks dygtigste digitale ledere - og samlet deres seks bedste råd om digitalisering og ledelse. Få alle rådene på 26 minutter i denne episode af podcasten The Digital Edge.
Job & Karriere
Se Waoos forklaring: Derfor har selskabet fyret topchef Jørgen Stensgaard med omgående virkning
Waaos bestyrelse opsiger fiberselskabets topchef, Jørgen Stensgaard, der fratræder med omgående virkning. Se hele forklaringen fra Waao her.
White paper
Sådan øger du medarbejdertilfredshed og produktivitet
En af de mest effektive måder at øge medarbejdernes produktivitet og tilfredshed med arbejdspladsen er ved at give frit valg mellem Windows eller Mac, når der skal vælges arbejdscomputer. Samtidig mindskes presset på supporten, mens sikkerhedsniveauet højnes. Med en client-as-a-service aftale kan du lade medarbejderne selv træffe valget, men uden at uden at det behøver at være udfordrende eller ressourcekrævende for virksomheden. Eksempelvis kan du lade partneren håndtere alt fra finansiering, leverance, klargøring og implementering til support og lifecycle-management. Læs mere i denne hvidbog.