Avatar billede Elle Novice
07. januar 2022 - 11:37 Der er 9 kommentarer og
1 løsning

Hvis 2 celler har samme match indsæt celle 3 i 4

Jeg prøver at få denne til at virke og fundet flere eksempler, men det virker ikke for mig?
Kolonne A indeholder et varenr.
Kolonne B indeholder en pris.
Kolonne C indeholder også et varenr.
Kolonne D resultat = Hvis C findes i A så indsæt B i D og ellers indsæt 0.

Har bla. forsøgt med nedenstående link, men de formler acceptere Excel ikke?
https://www.exceldemy.com/match-two-columns-in-excel-and-return-a-third/
Avatar billede jens48 Ekspert
07. januar 2022 - 11:48 #1
Prøv med:

=IF(COUNTIF(A:A;C1)>0;B1;0)

På Dansk:

=HVIS(TÆL.HVIS(A:A;C1)>0;B1;0)
Avatar billede jens48 Ekspert
07. januar 2022 - 12:02 #2
Glem #1. Det virker ikke
Avatar billede Elle Novice
07. januar 2022 - 12:06 #3
Ellers mange tak, det var godt på vej, men den tager værdien ud fra feltnr i A og ikke det unikke varenr. i kolonne A. :)
Avatar billede jens48 Ekspert
07. januar 2022 - 12:08 #4
=IF(COUNTIF(A:A;C1);INDEX(B:B;MATCH(C1;A:A));0)

På dansk:
=HVIS(TÆL:HVIS(A:A;C1);INDEKS(B:B;SAMMENLIGN(C1;A:A));0)
Avatar billede jens48 Ekspert
07. januar 2022 - 12:10 #5
Ups, jeg fik skrevet kolon i stedet for punktum i TÆL.HVIS
Avatar billede jens48 Ekspert
07. januar 2022 - 12:25 #6
Og hvis kolonne A ikke står i rækkefølge skal formelen ændres til

=IF(COUNTIF(A:A;C1);INDEX(B:B;MATCH(C1;A:A;));0)

=HVIS(TÆL.HVIS(A:A;C1);INDEKS(B:B;SAMMENLIGN(C1;A:A;));0)

Det ekstra semikolon i MATCH giver et eksakt match
Avatar billede Elle Novice
07. januar 2022 - 12:26 #7
Det returnerer enten N/A eller forkerte værdier?
Dog ser det ud som om at de varenumre som ikke findes i A returnere korrekt 0
Avatar billede Elle Novice
07. januar 2022 - 12:32 #8
Ser ud til at hvis varenr i A kommer før varenr. i C, så virker det?
Men hvis varrnr. i A står længere nede i arket end i C så fejler den? Giver det mening? :)
Avatar billede jens48 Ekspert
07. januar 2022 - 12:35 #9
Hvis du sætter det ekstra simikolon ind som vist i #6 burde det virke
Avatar billede Elle Novice
07. januar 2022 - 12:52 #10
Det er dælme lækkert, mange tak Jens og god weekend :-)
Avatar billede Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links. Der sættes "nofollow" på alle links.

Loading billede Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





CIO
Sådan tager top-CIO Pernille Geneser livtag med 40 år gamle it-systemer i Stark Group med 10.000 medarbejdere