Cisco MPLS netværk
HelloMe and my team mates are having a problem. We are doing our final exam, ending 5 years of IT education. An important part of our exam is related to networking, and we have run into a problem we hope some of
you might be able to help us with.
We have a setup with 4 VRF MPLS Routers, R1, R2, R3 and R4. We use IS-IS as our IGP and BGP to distribute VRF. We use VLANs and subinterfaces to simulate physical interfaces.
All routers are working within the same AS called "1337".
Our problem is that R4 gives us the following error upon a "debug ip cef drops"
Error - "No Parent Rewrite"
Nov 24 14:58:10.399: MPLS: Gi0/0.303: recvd: CoS=0, TTL=254, Label(s)=17
Nov 24 14:58:10.399: ICMP: echo reply sent, src 172.16.2.1, dst 172.16.0.1
Nov 24 14:58:10.399: mpls_process_pak_setup failed for 172.16.0.1: no parent rewrite
Nov 24 14:58:11.843: les_ip_to_tagswitch: no parent info for 172.16.0.1
Nov 24 14:58:12.399: MPLS: Gi0/0.303: recvd: CoS=0, TTL=254, Label(s)=17
Nov 24 14:58:12.399: ICMP: echo reply sent, src 172.16.2.1, dst 172.16.0.1
Nov 24 14:58:12.399: mpls_process_pak_setup failed for 172.16.0.1: no parent rewrite
The symptom is, that there is no connection (ping) from R1 to R4 in VRF RED, but the connection SEEMS to work fine inbetween R1, R2 and R3 in VRF RED.
R1 -- R3 --- R4
The configurations are as follows.
----------------------------------------R1--------------------------------------------------
hostname R1
!
ip cef
!
ip vrf RED
rd 1337:4
route-target export 1337:4
route-target import 1337:4
!
interface Loopback0
ip address 13.37.255.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.302
encapsulation dot1Q 302
ip address 13.37.2.1 255.255.255.240
ip router isis
mpls ip
!
interface FastEthernet0/0.340
encapsulation dot1Q 340
ip address 13.4.1.2 255.255.255.252
!
interface FastEthernet0/0.397
encapsulation dot1Q 397
ip vrf forwarding RED
ip address 172.16.0.1 255.255.255.0
!
interface FastEthernet0/0.399
encapsulation dot1Q 399
ip address 13.37.99.1 255.255.255.240
ip router isis
mpls ip
!
router isis
net 49.0001.0130.3725.5001.00
is-type level-2-only
passive-interface Loopback0
!
router bgp 1337
no synchronization
bgp log-neighbor-changes
network 13.37.2.0 mask 255.255.255.240
network 13.37.99.0 mask 255.255.255.240
network 13.37.255.1 mask 255.255.255.255
redistribute isis level-2
neighbor 13.4.1.1 remote-as 404
neighbor 13.37.255.2 remote-as 1337
neighbor 13.37.255.2 update-source Loopback0
neighbor 13.37.255.2 next-hop-self
neighbor 13.37.255.2 distribute-list 1 out
neighbor 13.37.255.3 remote-as 1337
neighbor 13.37.255.3 update-source Loopback0
neighbor 13.37.255.3 next-hop-self
neighbor 13.37.255.3 distribute-list 1 out
no auto-summary
!
address-family vpnv4
neighbor 13.37.255.3 activate
neighbor 13.37.255.3 send-community both
exit-address-family
!
address-family ipv4 vrf RED
redistribute connected
no synchronization
exit-address-family
!
access-list 1 deny 13.37.0.0 0.0.255.255
access-list 1 permit any
!
----------------------------------------R3--------------------------------------------------
!
hostname R3
!
ip cef
!
ip vrf RED
rd 1337:4
route-target export 1337:4
route-target import 1337:4
!
interface Loopback0
ip address 13.37.255.3 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.301
encapsulation dot1Q 301
ip address 13.37.1.3 255.255.255.240
ip router isis
no snmp trap link-status
mpls ip
isis circuit-type level-2-only
!
interface GigabitEthernet0/0.302
encapsulation dot1Q 302
ip address 13.37.2.3 255.255.255.240
ip router isis
no snmp trap link-status
mpls ip
isis circuit-type level-2-only
!
interface GigabitEthernet0/0.303
encapsulation dot1Q 303
ip address 13.37.3.3 255.255.255.240
ip router isis
no snmp trap link-status
mpls ip
isis circuit-type level-1
!
interface GigabitEthernet0/0.305
encapsulation dot1Q 305
ip vrf forwarding RED
ip address 172.16.1.1 255.255.255.0
no snmp trap link-status
!
router isis
net 49.0002.0130.3725.5003.00
passive-interface Loopback0
!
router bgp 1337
no synchronization
bgp log-neighbor-changes
neighbor 13.37.255.1 remote-as 1337
neighbor 13.37.255.1 update-source Loopback0
neighbor 13.37.255.1 route-reflector-client
neighbor 13.37.255.2 remote-as 1337
neighbor 13.37.255.2 update-source Loopback0
neighbor 13.37.255.2 route-reflector-client
neighbor 13.37.255.4 remote-as 1337
neighbor 13.37.255.4 update-source Loopback0
neighbor 13.37.255.4 route-reflector-client
no auto-summary
!
address-family vpnv4
neighbor 13.37.255.1 activate
neighbor 13.37.255.1 send-community both
neighbor 13.37.255.1 route-reflector-client
neighbor 13.37.255.2 activate
neighbor 13.37.255.2 send-community both
neighbor 13.37.255.2 route-reflector-client
neighbor 13.37.255.4 activate
neighbor 13.37.255.4 send-community both
neighbor 13.37.255.4 route-reflector-client
exit-address-family
!
address-family ipv4 vrf RED
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
----------------------------------------R4--------------------------------------------------
hostname R4
!
ip cef
!
ip vrf GREEN
rd 1337:8
route-target export 1337:8
route-target import 1337:8
!
ip vrf RED
rd 1337:4
route-target export 1337:4
route-target import 1337:4
!
interface Loopback0
ip address 13.37.255.4 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.303
encapsulation dot1Q 303
ip address 13.37.3.4 255.255.255.240
ip router isis
mpls ip
!
interface GigabitEthernet0/0.307
encapsulation dot1Q 307
ip vrf forwarding RED
ip address 172.16.2.1 255.255.255.0
!
interface GigabitEthernet0/0.308
encapsulation dot1Q 308
ip vrf forwarding GREEN
ip address 192.168.2.1 255.255.255.0
!
router isis
net 49.0002.0130.3725.5004.00
is-type level-1
passive-interface Loopback0
!
router bgp 1337
no synchronization
bgp log-neighbor-changes
neighbor 13.37.255.3 remote-as 1337
neighbor 13.37.255.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 13.37.255.3 activate
neighbor 13.37.255.3 send-community both
exit-address-family
!
address-family ipv4 vrf RED
redistribute connected
no synchronization
exit-address-family
!
address-family ipv4 vrf GREEN
redistribute connected
no synchronization
exit-address-family
!