boro23 Seniormester
19. januar 2021 - 11:04 Der er 12 kommentarer og
1 løsning

Formelhjælp

Findes der en formel der kan gruppere tekst i alfabetisk rækkefølge ud fra en matrix, ligesom hvis jeg brugte "MINDSTE" med en tal matrix?
mikh Juniormester
19. januar 2021 - 11:12 #1
Hvilket program taler vi om?
mikh Juniormester
19. januar 2021 - 11:12 #2
Jeg ser nu at det er EXcel
mikh Juniormester
19. januar 2021 - 11:24 #3
Hvis du bruger funtionen code(karakter) bliver bogstaver omregnet til værdier og du kan derefter bruge min(værdi) = "MINDSTE".

Dette gælder hvis det er enkelt bogatver.
Hvis det er ord og du vil sortere på flere bogstaver pr. ord er du nødt til invovere funktioner, som læser de enkelte bogstaver fra hvert ord. Disse funktioner findes i Excel, men det bliver relativt lange og komplekse formler.
ebea Ekspert
19. januar 2021 - 11:25 #4
Jeg ved ikke lige, hvad du mener med at gruppere. Men hvis det er at liste dem alfabetisk, kan du prøve med denne formel. Ellers forklar lidt mere specifikt.

=INDEKS($A$1:$A$10;SAMMENLIGN(RÆKKER($A$1:A1);TÆL.HVIS($A$1:$A$10;"<="&$A$1:$A$10);0))

Formlen skal indtastes med Ctrl + Shift og Enter, så du får de 2 {  }  klammer i start og slut af formlen.
mikh Juniormester
19. januar 2021 - 11:29 #5
Her et eksempel:
a    v                          Dette er de bogstaver, hvor du skal fimde det mindste.
b    g
h    k
   
97    118                    Her er hver enkelt bogstav omdannet til deres værdi med
98    103                    code(bogstav)
104    107
   
97                              Her er den mindste værdi i matrixen fundet

Den kan laves om til bogsav med funktionen char(97) der giver "a".

Håber at dette fører dig på sporet.
boro23 Seniormester
19. januar 2021 - 12:06 #6
mihk: er kun intresseret i en formel løsning (måske VBA)
ebea: Teksten ser således ud i Kol. B, starter fra række 10,der forekommer tomme celler mellem teksterne. Jeg vil gerne dem listet i alfabetisk rækkefølge i Kol. C fra række 10, håber det giver mere mening.;-)

ROS0774631


ROS0774672
ROS0774686
ROS0774726

ROS0774727
ROS0774885


ROS0774929

ROS0774930
ebea Ekspert
19. januar 2021 - 12:47 #7
#6 - Har du prøvet formlen?. Den lister den opstilling du har vist, sorteret.
=INDEKS($B$10:$B$25;SAMMENLIGN(RÆKKER($B10:B$10);TÆL.HVIS($B$10:$B$25;"<="&$B$10:$B$25);0))
jens48 Ekspert
19. januar 2021 - 12:49 #8
Måske kan denne makro btuges. Den kopierer det der står i kolonne B over i kolonne C, og sorterer på kolonne C alene.

Sub Sorter()
Dim LastRow As Long
LastRow = Cells(65356, 2).End(xlUp).Row
Range("B2:B" & LastRow).Copy Destination:=Range("C2")
Range("C2:C" & LastRow).Select
    ActiveWorkbook.Worksheets("Sheet1").Sort.SortFields.Clear
    ActiveWorkbook.Worksheets("Sheet1").Sort.SortFields.Add2 Key:=Range("C2:C1" & LastRow) _
        , SortOn:=xlSortOnValues, Order:=xlAscending, DataOption:=xlSortNormal
    With ActiveWorkbook.Worksheets("Sheet1").Sort
        .SetRange Range("C2:C1" & LastRow)
        .Header = xlGuess
        .MatchCase = False
        .Orientation = xlTopToBottom
        .SortMethod = xlPinYin
        .Apply
    End With
    Range("C2").Select

End Sub
boro23 Seniormester
19. januar 2021 - 13:07 #9
ebea #7: Ja det har jeg, den lister godtnok uden tomme celler, men ikke alfabetisk. Kan det være fordi der er tal i teksten?
ebea Ekspert
19. januar 2021 - 13:32 #10
#9 - Formlen angivet i #7, har jeg testet på de data som du angav. Og der listes korrekt i alfabetisk rækkefølge, inklusiv tallene.
boro23 Seniormester
19. januar 2021 - 13:59 #11
ebea, du har fuldstændig ret, det var bare mig der ikke havde øjnene med mig ;-)
1000 tak for hjælpen.
ebea Ekspert
19. januar 2021 - 14:24 #12
#11 - Du er velkommen ;-)

PS: Hvis du fik løst dit spørgsmål, så luk det venligst ;-)
ebea Ekspert
19. januar 2021 - 14:28 #13
Se bort fra det med at lukke spørgsmålet. Jeg havde ikke set det. :-)
Ny bruger Nybegynder

Din løsning...

Tilladte BB-code-tags: [b]fed[/b] [i]kursiv[/i] [u]understreget[/u] Web- og emailadresser omdannes automatisk til links

Opret Preview

Log ind eller opret profil

Hov!

For at kunne deltage på Computerworld Eksperten skal du være logget ind.

Det er heldigvis nemt at oprette en bruger: Det tager to minutter og du kan vælge at bruge enten e-mail, Facebook eller Google som login.

Du kan også logge ind via nedenstående tjenester





Premium
Bankdata efter hård kritik af it-sikkerheden fra Finanstilsynet: Vi kan godt genkende kritikken
Interview: Bankdata kan godt nikke genkendende til den række af kritik-punkter, som Finanstilsynet retter mod selskabets it-sikkerhed. Men der er en god forklaring, mener compliance-direktør Lene Weldum.
Computerworld
Spotify på vej med kæmpe satsning: Vil være mere end blot en musikstreamingtjeneste
Svenske Spotify er klar med en række nyheder, der rækker længere end blot lyd.
CIO
Der findes ikke noget vigtigere for din virksomhedskultur end psychological safety
Klumme: Forskningen er entydig: Vidensarbejde er mere effektiv, når du tør stille spørgsmål, rejse kritik og indrømme fejl helt uden frygt for at blive straffet eller gjort til grin. Hvis du ikke har fokus på denne del af din virksomhedskultur, så lever din virksomhed og dine medarbejdere ikke op til deres fulde potentiale.
Job & Karriere
IBM Danmark trækker tilbud om frivillige fratrædelser tilbage for stort antal ansatte: "IBM har taget røven på sine ansatte"
Som led i IBM Danmarks store fyringsrunde fik 130 ansatte grønt lys til at forlade selskabet på en frivillig fratrædelsesordning. Men nu har IBM Danmark trukket det oprindelige tilbud tilbage for størstedelen af de ansatte.
White paper
Fri medarbejdermobilitet - med digital bodyguard
Om at gå fra adgangsstyring på personniveau til adgangsstyring på desktopniveau. I takt med at flere og flere medarbejdere arbejder remote og logger på jeres systemer og netværk uden for virksomhedens sikkerhedsværn, risikerer de at efterlade døren til forretningen på klem. Dermed bliver endpoints som pc’ere, Mac’s og servere et oplagt mål for hackere, som vil ind i virksomhedens infrastruktur. I blandt sker det også, at medarbejdere udnytter deres privilegerede adgangsrettigheder til skadelige formål. Det er derfor mere aktuelt end nogensinde at rette opmærksomheden mod jeres endpoints og de rettigheder, der ligger her.